google_mobile_ads 0.12.2
google_mobile_ads: ^0.12.2 copied to clipboard

Flutter plugin for Google Mobile Ads, supporting banner, interstitial (full-screen), rewarded and native ads

468
likes
110 / 130
pub points
97 %
popularity

We analyzed this package on May 13, 2021, and awarded it 110 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 147 out of 151 API elements (97.4 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Found 6 issues. Showing the first 2:

Consider supporting multiple platforms:

Package does not support Flutter platform Web

Because:

  • package:google_mobile_ads/google_mobile_ads.dart that declares support for platforms: Android, iOS
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 5 issues. Showing the first 2:

INFO: Override `hashCode` if overriding `==`.

lib/src/ad_containers.dart:93:17

   ╷
93 │   bool operator ==(Object other) {
   │                 ^^
   ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/src/ad_containers.dart

INFO: Override `hashCode` if overriding `==`.

lib/src/ad_containers.dart:134:17

    ╷
134 │   bool operator ==(Object other) {
    │                 ^^
    ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/src/ad_containers.dart

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
flutterflutter0.0.00.0.0
meta^1.0.41.3.01.3.0
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.01.1.0
collection-1.15.01.15.0
sky_engine-0.0.990.0.99
typed_data-1.3.01.3.0
vector_math-2.1.02.1.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
20 / 20

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.16.0, Flutter 2.0.6, Dart 2.12.3.

468
likes
110
pub points
97%
popularity

Publisher

google.dev

Flutter plugin for Google Mobile Ads, supporting banner, interstitial (full-screen), rewarded and native ads

Homepage
Repository (GitHub)
View/report issues

Documentation

API reference

License

Apache 2.0 (LICENSE)

Dependencies

flutter, meta

More

Packages that depend on google_mobile_ads