google_maps_markerwithlabel 0.1.1

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • 16

google_maps_markerwithlabel #

Dart wrapper for Google Maps MarkerWithLabel utility library. https://github.com/googlemaps/v3-utility-library/tree/master/markerwithlabel

Thanks to @a14n for https://github.com/a14n/dart-google-maps and https://github.com/a14n/dart-js-wrapping

Changelog #

0.1.1 #

0.1.0 #

  • Initial version

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  google_maps_markerwithlabel: ^0.1.1

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:google_maps_markerwithlabel/markerwithlabel.dart';
  
Version Uploaded Documentation Archive
0.3.0 Aug 7, 2018 Go to the documentation of google_maps_markerwithlabel 0.3.0 Download google_maps_markerwithlabel 0.3.0 archive
0.2.0+1 Jul 30, 2018 Go to the documentation of google_maps_markerwithlabel 0.2.0+1 Download google_maps_markerwithlabel 0.2.0+1 archive
0.2.0 Jul 30, 2018 Go to the documentation of google_maps_markerwithlabel 0.2.0 Download google_maps_markerwithlabel 0.2.0 archive
0.1.1 Apr 4, 2018 Go to the documentation of google_maps_markerwithlabel 0.1.1 Download google_maps_markerwithlabel 0.1.1 archive
0.1.0 Aug 28, 2017 Go to the documentation of google_maps_markerwithlabel 0.1.0 Download google_maps_markerwithlabel 0.1.0 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
32
Health:
Code health derived from static analysis. [more]
--
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
--
Overall:
Weighted score of the above. [more]
16
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://dart.dev/dart-2#migration.

Maintenance issues and suggestions

Make sure dartdoc successfully runs on your package's source files. (-10 points)

Dependencies were not resolved.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.20.1 <2.0.0