google_maps_markerclusterer 0.1.2

  • Readme
  • Changelog
  • Installing
  • 53

google_maps_markerclusterer #

Dart wrapper for Google Maps MarkerClusterer utility library.

Thanks to @a14n for and

Changelog #

0.1.2 #

  • Dart 2 stable

0.1.1 #

  • Align with latest version

0.1.0 #

  • Initial version

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  google_maps_markerclusterer: ^0.1.2

2. Install it

You can install packages from the command line:

with pub:

$ pub get

with Flutter:

$ flutter pub get

Alternatively, your editor might support pub get or flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:google_maps_markerclusterer/markerclusterer.dart';
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

We analyzed this package on Apr 8, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.7.1
  • pana: 0.13.6

Health issues and suggestions

Document public APIs. (-1 points)

59 out of 59 API elements have no dartdoc comment.Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API.

Format lib/src/markerclusterer.dart.

Run dartfmt to format lib/src/markerclusterer.dart.

Maintenance suggestions

Package is getting outdated. (-63.56 points)

The package was last published 85 weeks ago.

Maintain an example.

None of the files in the package's example/ directory matches known example patterns.

Common filename patterns include main.dart, example.dart, and google_maps_markerclusterer.dart. Packages with multiple examples should provide example/

For more information see the pub package layout conventions.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.20.1 <3.0.0
google_maps ^3.3.0 3.4.1
js_wrapping ^0.5.0 0.5.0
Transitive dependencies
meta 1.1.8
Dev dependencies
build_runner ^0.9.0
build_web_compilers ^0.4.0
html ^0.13.0
js_wrapping_generator ^0.5.0
test ^1.3.0