google_map_fluttify 0.0.1
google_map_fluttify: ^0.0.1

Flutter Android iOS

An `Google Map` Map Component, Powered By `Fluttify` Compiler, A Dart Bindings Generator For Native SDK.

0
likes
60 / 110
pub points
9 %
popularity

We analyzed this package on Dec 1, 2020, and awarded it 60 pub points (of a possible 110):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

Homepage URL doesn't exist.

At the time of the analysis https://github.com/fluttify-project/google_map_fluttify was unreachable.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 101 out of 269 API elements (37.5 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Found 6 issues. Showing the first 2:

Consider supporting multiple platforms:

Package does not support Flutter platform Web

Because:

  • package:google_map_fluttify/google_map_fluttify.dart that declares support for platforms: Android, iOS
Pass static analysis
10 / 30

10/30 points: code has no errors, warnings, lints, or formatting issues

Found 261 issues. Showing the first 2:

WARNING: The parameter 'tag' is required.

lib/src/facade/google_map_view.widget.dart:138:14

    ╷
138 │       return ScopedReleasePool(
    │              ^^^^^^^^^^^^^^^^^
    ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/src/facade/google_map_view.widget.dart

WARNING: The parameter 'tag' is required.

lib/src/facade/google_map_view.widget.dart:181:14

    ╷
181 │       return ScopedReleasePool(
    │              ^^^^^^^^^^^^^^^^^
    ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/src/facade/google_map_view.widget.dart

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
core_location_fluttify^0.4.00.4.10.6.0
foundation_fluttify^0.9.4+20.9.10+10.11.1
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.0-nullsafety.51.1.0-nullsafety.5
collection-1.15.0-nullsafety.51.15.0-nullsafety.5
meta-1.3.0-nullsafety.61.3.0-nullsafety.6
typed_data-1.3.0-nullsafety.51.3.0-nullsafety.5
vector_math-2.1.0-nullsafety.52.1.0-nullsafety.5

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.4.0` on core_location_fluttify does not support the latest published version `0.6.0`

pubspec.yaml:16:27

   ╷
16 │   core_location_fluttify: ^0.4.0
   │                           ^^^^^^
   ╵
The constraint `^0.9.4+2` on foundation_fluttify does not support the latest published version `0.11.1`

pubspec.yaml:15:24

   ╷
15 │   foundation_fluttify: ^0.9.4+2
   │                        ^^^^^^^^
   ╵

10/10 points: Package supports latest stable Dart and Flutter SDKs

0
likes
60
pub points
9%
popularity

An `Google Map` Map Component, Powered By `Fluttify` Compiler, A Dart Bindings Generator For Native SDK.

Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

yohombao@gmail.com

License

Apache 2.0 (LICENSE)

Dependencies

core_location_fluttify, flutter, foundation_fluttify

More

Packages that depend on google_map_fluttify