go_router_plus 4.1.1 copy "go_router_plus: ^4.1.1" to clipboard
go_router_plus: ^4.1.1 copied to clipboard

Building blocks screens, access control and refresh notifiers base on Go Router.

28
likes
130/ 160
pub points
60%
popularity

We analyzed this package 3 days ago, and awarded it 130 pub points (of a possible 160):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

167 out of 167 API elements (100.0 %) have documentation comments.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS
  • ✓ Web
failed
Pass static analysis
30 / 50trigger folding of the section

30/50 points: code has no errors, warnings, lints, or formatting issues

WARNING: Doc directive 'macro:' is unknown.

lib/src/screen.dart:22:9

   ╷
22 │   /// {@macro: go_router_plus.screen.screen_controller}
   │         ^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/screen.dart

failed
Support up-to-date dependencies
30 / 40trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
flutter flutter 0.0.0 0.0.0
go_router ^6.5.2 6.5.9 14.2.0
meta ^1.8.0 1.12.0 1.15.0
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
collection - 1.18.0 1.19.0
flutter_web_plugins - 0.0.0 0.0.0
logging - 1.2.0 1.2.0
material_color_utilities - 0.8.0 0.12.0
sky_engine - 0.0.99 0.0.99
vector_math - 2.1.4 2.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^6.5.2` on go_router does not support the stable version `7.0.0`.

Try running dart pub upgrade --major-versions go_router to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

20/20 points: Compatible with dependency constraint lower bounds

pub downgrade does not expose any static analysis error.

Analyzed with Pana 0.22.7, Flutter 3.22.2, Dart 3.4.3.

Check the analysis log for details.

28
likes
130
pub points
60%
popularity

Publisher

verified publishercovalab.io

Building blocks screens, access control and refresh notifiers base on Go Router.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

flutter, go_router, meta

More

Packages that depend on go_router_plus