gma_mediation_pangle 1.1.0 copy "gma_mediation_pangle: ^1.1.0" to clipboard
gma_mediation_pangle: ^1.1.0 copied to clipboard

Mediation Adapter that enables sending ad requests to the Pangle ad network using the google_mobile_ads plugin.

2
likes
160/ 160
pub points
80%
popularity

We analyzed this package 5 days ago, and awarded it 160 pub points (of a possible 160):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: Apache-2.0.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

1 out of 2 API elements (50.0 %) have documentation comments.

Some symbols that are missing documentation: gma_mediation_pangle.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 2 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS

These platforms are not supported:

Package does not support platform `Windows`.

Because:

  • package:gma_mediation_pangle/gma_mediation_pangle.dart that declares support for platforms: Android, iOS.
Package does not support platform `Linux`.

Because:

  • package:gma_mediation_pangle/gma_mediation_pangle.dart that declares support for platforms: Android, iOS.
Package does not support platform `macOS`.

Because:

  • package:gma_mediation_pangle/gma_mediation_pangle.dart that declares support for platforms: Android, iOS.
Package does not support platform `Web`.

Because:

  • package:gma_mediation_pangle/gma_mediation_pangle.dart that declares support for platforms: Android, iOS.
OK
Pass static analysis
50 / 50trigger folding of the section

50/50 points: code has no errors, warnings, lints, or formatting issues

OK
Support up-to-date dependencies
40 / 40trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
flutter flutter 0.0.0 0.0.0
google_mobile_ads ^5.1.0 5.1.0 5.1.0
plugin_platform_interface ^2.0.2 2.1.8 2.1.8
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
collection - 1.18.0 1.19.0
material_color_utilities - 0.8.0 0.12.0
meta - 1.12.0 1.15.0
path - 1.9.0 1.9.0
sky_engine - 0.0.99 0.0.99
vector_math - 2.1.4 2.1.4
webview_flutter - 4.8.0 4.8.0
webview_flutter_android - 3.16.4 3.16.4
webview_flutter_platform_interface - 2.10.0 2.10.0
webview_flutter_wkwebview - 3.14.0 3.14.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

20/20 points: Compatible with dependency constraint lower bounds

pub downgrade does not expose any static analysis error.

Analyzed with Pana 0.22.8, Flutter 3.22.2, Dart 3.4.3.

Check the analysis log for details.

2
likes
160
pub points
80%
popularity

Publisher

verified publishergoogle.dev

Mediation Adapter that enables sending ad requests to the Pangle ad network using the google_mobile_ads plugin.

Repository (GitHub)
View/report issues
Contributing

Documentation

API reference

License

Apache-2.0 (license)

Dependencies

flutter, google_mobile_ads, plugin_platform_interface

More

Packages that depend on gma_mediation_pangle