github_contributions 0.1.1

github_contributions #

build pub

A library to get GitHub users' contributions information, for Dart and Flutter developers

Usage #

main() async {
  var login = 'pd4d10'; // replace this with GitHub account you want

  // get svg string
  String svg = await getContributionsSvg(login, withoutText: true);
  print(svg);

  // get color and count of this year's contribution
  var contributions = await getContributions(login);
  print(contributions[0].color);
}

License #

MIT

0.1.0 #

  • Initial version, created by Stagehand

0.1.1 #

  • Breaking change: withoutText -> keepDateText
  • Fix svg size

example/github_contributions_example.dart

import 'package:github_contributions/github_contributions.dart';

main() async {
  var login = 'pd4d10'; // replace this with GitHub account you want

  // get svg string
  String svg = await getContributionsSvg(login);
  print(svg);

  // get color and count of this year's contribution
  var contributions = await getContributions(login);
  print(contributions[0].color);
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  github_contributions: ^0.1.1

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter pub get

Alternatively, your editor might support pub get or flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:github_contributions/github_contributions.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
40
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
90
Overall:
Weighted score of the above. [more]
68
Learn more about scoring.

We analyzed this package on Jul 17, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.4.0
  • pana: 0.12.19

Platforms

Detected platforms: Flutter, web, other

No platform restriction found in primary library package:github_contributions/github_contributions.dart.

Maintenance issues and suggestions

Support latest dependencies. (-10 points)

The version constraint in pubspec.yaml does not support the latest published versions for 1 dependency (html).

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
html ^0.13.3 0.13.4+2 0.14.0+2
http ^0.12.0 0.12.0+2
Transitive dependencies
async 2.3.0
charcode 1.1.2
collection 1.14.11
csslib 0.15.0 0.16.1
http_parser 3.1.3
meta 1.1.7
path 1.6.2
source_span 1.5.5
string_scanner 1.0.4
term_glyph 1.1.0
typed_data 1.1.6
utf 0.9.0+5
Dev dependencies
pedantic ^1.0.0 1.8.0+1
test ^1.0.0

Admin