git_version 0.3.0 icon indicating copy to clipboard operation
git_version: ^0.3.0 copied to clipboard

Replaces the '%version%' placeholder with your current git version

0
likes
75/ 130
pub points
0%
popularity

We analyzed this package 23 hours ago, and awarded it 75 pub points (of a possible 130):

icon indicating section status
Follow Dart file conventions
15 / 20icon to trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

0/5 points: Provide a valid CHANGELOG.md

Links in `CHANGELOG.md` should be secure. 2 links are insecure.

CHANGELOG.md:3:5

  ╷
3 │ <h2><a href="http://github.com/mikemitterer/dart-git_version/compare/v0.2...HEAD">Unreleased</a></h2>
  │     ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

Use https URLs instead.

icon indicating section status
Provide documentation
10 / 20icon to trigger folding of the section

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

10/10 points: 20% or more of the public API has dartdoc comments

  • 12 out of 19 API elements (63.2 %) have documentation comments.
icon indicating section status
Platform support
20 / 20icon to trigger folding of the section

20/20 points: Supports 5 of 6 possible platforms (iOS, Android, Web, Windows, MacOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ MacOS

These platforms are not supported:

Package not compatible with platform Web

Because:

  • package:git_version/git_version.dart that imports:
  • package:where/where.dart that imports:
  • package:where/src/io.dart that imports:
  • dart:io
icon indicating section status
Pass static analysis
20 / 30icon to trigger folding of the section

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 7 issues. Showing the first 2:

INFO: Name source files using `lowercase_with_underscores`.

To reproduce make sure you are using the lints_core and run dart analyze bin/showGitVersion.dart

INFO: The import of 'package:logging/logging.dart' is unnecessary because all of the used elements are also provided by the import of 'package:console_log_handler/print_log_handler.dart'.

bin/showGitVersion.dart:3:8

  ╷
3 │ import 'package:logging/logging.dart';
  │        ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run dart analyze bin/showGitVersion.dart

icon indicating section status
Support up-to-date dependencies
10 / 20icon to trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
build^0.12.00.12.82.3.0
console_log_handler^1.0.01.1.61.1.6
logging>=0.11.3 <1.0.00.11.41.0.2
where^4.0.04.4.08.0.0
Transitive dependencies
PackageConstraintCompatibleLatest
analyzer-0.32.64.1.0
ansicolor-1.1.12.0.1
args-1.6.02.3.1
async-2.9.02.9.0
build_cli_annotations-1.2.02.0.0
charcode-1.3.11.3.1
clock-1.1.01.1.0
collection-1.16.01.16.0
convert-2.1.13.0.1
crypto-2.1.53.0.2
csslib-0.17.10.17.1
file-5.2.16.1.2
front_end-0.1.4+20.1.29
glob-1.2.02.0.2
html-0.15.00.15.0
intl-0.17.00.17.0
js-0.6.40.6.4
kernel-0.3.4+20.3.29
meta-1.7.01.7.0
node_interop-1.2.12.1.0
node_io-1.2.02.1.0
package_config-1.9.32.0.2
path-1.8.11.8.1
pedantic-1.11.11.11.1
plugin-0.2.0+30.2.0+3
source_span-1.9.01.9.0
string_scanner-1.1.11.1.1
term_glyph-1.2.01.2.0
typed_data-1.3.11.3.1
watcher-0.9.7+151.0.1
yaml-2.2.13.1.1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 3 issues. Showing the first 2:

The constraint `^0.12.0` on build does not support the stable version `1.0.0`.

Try running dart pub upgrade --major-versions build to update the constraint.

The constraint `>=0.11.3 <1.0.0` on logging does not support the stable version `1.0.0`.

Try running dart pub upgrade --major-versions logging to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

icon indicating section status
Support sound null safety
0 / 20icon to trigger folding of the section

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.0.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.21.12, Dart 2.17.0.

0
likes
75
pub points
0%
popularity

Publisher

unverified uploader

Replaces the '%version%' placeholder with your current git version

Repository (GitHub)
View/report issues

Documentation

API reference

License

BSD-3-Clause (LICENSE)

Dependencies

build, console_log_handler, logging, where

More

Packages that depend on git_version