geolocator 5.3.2+2

Flutter Android iOS

Geolocation plugin for Flutter. This plugin provides a cross-platform (iOS, Android) API for generic location (GPS etc.) functions.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

dependencies:
  geolocator: ^5.3.2+2

2. Install it

You can install packages from the command line:

with Flutter:

$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:geolocator/geolocator.dart';
664
likes
95
pub points
99%
popularity

Publisher

baseflow.com

Geolocation plugin for Flutter. This plugin provides a cross-platform (iOS, Android) API for generic location (GPS etc.) functions.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

equatable, flutter, google_api_availability, location_permissions, meta, vector_math

More

Packages that depend on geolocator