generate 0.2.1+3
generate: ^0.2.1+3 copied to clipboard

dart cui tools.generate some project template or class for my styles.

0
likes
65 / 130
pub points
29 %
popularity

We analyzed this package on May 8, 2021, and awarded it 65 pub points (of a possible 130):

Follow Dart file conventions
15 / 20

10/10 points: Provide a valid pubspec.yaml

0/5 points: Provide a valid README.md

`README.md` contains too many non-ASCII characters.

The site uses English as its primary language. The content of README.md in your package should primarily contain characters used in English.

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
0 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

0/10 points: 20% or more of the public API has dartdoc comments

  • 3 out of 76 API elements (3.9 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:generate/generate.dart that imports:
  • package:generate/cmd/completion.dart that imports:
  • package:mustache/mustache.dart that imports:
  • package:mustache/src/template.dart that imports:
  • package:mustache/src/renderer.dart that imports:
  • dart:mirrors
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 17 issues. Showing the first 2:

INFO: 'package:resource/resource.dart' is deprecated and shouldn't be used. This package has been discontinued. See library documentation of README.md for more infomration.

lib/cmd/completion.dart:5:1

  ╷
5 │ import 'package:resource/resource.dart' show Resource;
  │ ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/cmd/completion.dart

INFO: This function has a return type of 'int', but doesn't end with a return statement.

lib/cmd/completion.dart:25:14

   ╷
25 │       execute: (command, results) {
   │ ┌──────────────^
26 │ │       if (results["help"]) {
27 │ │         print(command.usage);
28 │ │       } else {
29 │ │         final controller = StreamController<int>();
30 │ │         controller.stream.listen((v) {
31 │ │           exitCode = v ?? 0;
32 │ │         });
33 │ │         () async {
34 │ │           final output = results["output"];
35 │ │           IOSink writer;
36 │ │           if (output == null) {
37 │ │             writer = stdout;
38 │ │           } else {
39 │ │             var file = File(output);
40 │ │             file = await file.create(recursive: false);
41 │ │             writer = file.openWrite();
42 │ │           }
43 │ │           final resource = Resource("package:generate/assets/completion.sh");
44 │ │           final source = await resource.readAsString(encoding: utf8);
45 │ │           final template = Template(
46 │ │             source,
47 │ │             htmlEscapeValues: false,
48 │ │           );
49 │ │           writer.write(template.renderString({
50 │ │             "tag": "__king011_generate",
51 │ │             "environment": Environment(),
52 │ │           }));
53 │ │           if (output != null) {
54 │ │             await writer.close();
55 │ │           }
56 │ │         }();
57 │ │       }
58 │ │     },
   │ └─────^
   ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/cmd/completion.dart

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
mustache^1.1.11.1.11.1.1
path^1.6.21.8.01.8.0
resource^2.1.52.1.72.1.7
wrapper_args^1.0.01.0.1+11.0.1+1
Transitive dependencies
PackageConstraintCompatibleLatest
args-1.6.02.1.0
collection-1.15.01.15.0
typed_data-1.3.01.3.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.1.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.16.0, Dart 2.12.4.

0
likes
65
pub points
29%
popularity

dart cui tools.generate some project template or class for my styles.

Repository (GitLab)
View/report issues

Documentation

API reference

Uploader

zuiwuchang@gmail.com

License

BSD (LICENSE)

Dependencies

mustache, path, resource, wrapper_args

More

Packages that depend on generate