gender_selector 1.0.6
gender_selector: ^1.0.6 copied to clipboard

Flutter Android iOS Linux macOS web Windows

A Flutter Package for gender selector widget for the app. Using this package you can allow the user to select the gender by the beautiful widget. Show your love on this package.

6
likes
80 / 110
pub points
75 %
popularity

We analyzed this package on Feb 26, 2021, and awarded it 80 pub points (of a possible 110):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

Homepage URL doesn't exist.

At the time of the analysis https://github.com/dhruvil2000/gender_selector_flutter was unreachable.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

0/10 points: 20% or more of the public API has dartdoc comments

  • 2 out of 25 API elements (8.0 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
20 / 20

20/20 points: Supports 3 of 3 possible platforms (iOS, Android, Web)

Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

INFO: This class (or a class that this class inherits from) is marked as '@immutable', but one or more of its instance fields aren't final: GenderSelector.maleimg, GenderSelector.femaleimg, GenderSelector.maletxt, GenderSelector.femaletxt, GenderSelector.padding, GenderSelector.margin, GenderSelector.selectedGender, GenderSelector.onChanged

lib/gender_selector.dart:7:7

  ╷
7 │ class GenderSelector extends StatefulWidget {
  │       ^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/gender_selector.dart

lib/gender_selector.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
flutterflutter0.0.00.0.0
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.0-nullsafety.31.1.0
collection-1.15.0-nullsafety.31.15.0
meta-1.3.0-nullsafety.31.3.0
sky_engine-0.0.990.0.99
typed_data-1.3.0-nullsafety.31.3.0
vector_math-2.1.0-nullsafety.32.1.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analysed with Pana 0.14.10, Flutter 1.22.6, Dart 2.10.5.

6
likes
80
pub points
75%
popularity

A Flutter Package for gender selector widget for the app. Using this package you can allow the user to select the gender by the beautiful widget. Show your love on this package.

Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

dhruvilscreation@gmail.com

License

Apache 2.0 (LICENSE)

Dependencies

flutter

More

Packages that depend on gender_selector