galileo_sembast 3.0.0
galileo_sembast: ^3.0.0 copied to clipboard

package:sembast-powered CRUD services for the Galileo framework.

1
likes
70 / 130
pub points
0 %
popularity

We analyzed this package on Jul 28, 2021, and awarded it 70 pub points (of a possible 130):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

Homepage URL doesn't exist.

At the time of the analysis https://github.com/galileo-dart/sembast was unreachable.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 9 out of 14 API elements (64.3 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:galileo_sembast/galileo_sembast.dart that imports:
  • package:galileo_framework/galileo_framework.dart that imports:
  • package:galileo_framework/src/core/core.dart that imports:
  • package:galileo_framework/src/core/service.dart that imports:
  • package:galileo_framework/src/core/server.dart that imports:
  • package:galileo_framework/src/core/routable.dart that imports:
  • package:galileo_framework/src/core/response_context.dart that imports:
  • package:galileo_framework/src/core/request_context.dart that imports:
  • package:galileo_http_server/galileo_http_server.dart that imports:
  • package:galileo_http_server/src/http_multipart_form_data.dart that imports:
  • dart:io
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

lib/galileo_sembast.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
galileo_framework^3.0.23.0.24.0.0
sembast^3.0.23.1.0+23.1.0+2
Transitive dependencies
PackageConstraintCompatibleLatest
async-2.8.12.8.1
boolean_selector-2.1.02.1.0
charcode-1.3.11.3.1
collection-1.15.01.15.0
crypto-3.0.13.0.1
essential_code_buffer-2.0.12.0.1
file-6.1.26.1.2
galileo_combinator-1.1.14.0.3
galileo_container-2.2.24.0.4
galileo_http_server-1.0.11.0.1
galileo_merge_map-1.0.24.0.0
galileo_mock_request-1.0.84.0.0
galileo_model-2.0.04.0.0
galileo_route-5.0.16.0.1
http2-2.0.02.0.0
http_parser-4.0.04.0.0
matcher-0.12.100.12.10
meta-1.7.01.7.0
mime-1.0.01.0.0
path-1.8.01.8.0
quiver-3.0.13.0.1
recase-4.0.04.0.0
source_span-1.8.11.8.1
stack_trace-1.10.01.10.0
stream_channel-2.1.02.1.0
string_scanner-1.1.01.1.0
synchronized-3.0.03.0.0
term_glyph-1.2.01.2.0
test_api-0.4.20.4.2
tuple-2.0.02.0.0
typed_data-1.3.01.3.0
uuid-3.0.43.0.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^3.0.2` on galileo_framework does not support the stable version `4.0.0`.

Try running dart pub upgrade --major-versions galileo_framework to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.10.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.19.0, Dart 2.13.4.

1
likes
70
pub points
0%
popularity

Publisher

galileodart.com

package:sembast-powered CRUD services for the Galileo framework.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

galileo_framework, sembast

More

Packages that depend on galileo_sembast