galileo_prompts 2.0.0 copy "galileo_prompts: ^2.0.0" to clipboard
galileo_prompts: ^2.0.0 copied to clipboard

Rich, simple, synchronous command-line prompt library for Dart.

0
likes
120/ 140
pub points
0%
popularity

We analyzed this package 21 hours ago, and awarded it 120 pub points (of a possible 140):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

8 out of 9 API elements (88.9 %) have documentation comments.

Some symbols that are missing documentation: galileo_prompts.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 5 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS

These platforms are not supported:

Package not compatible with platform Web

Because:

  • package:galileo_prompts/galileo_prompts.dart that imports:
  • package:io/ansi.dart that imports:
  • package:io/src/ansi_code.dart that imports:
  • dart:io
failed
Pass static analysis
30 / 50trigger folding of the section

30/50 points: code has no errors, warnings, lints, or formatting issues

Found 9 issues. Showing the first 2:

WARNING: The operand can't be null, so the condition is always 'false'.

lib/galileo_prompts.dart:169:27

    ╷
169 │     message += defaultsTo == null ? ' (y/n)' : (defaultsTo ? ' (Y/n)' : ' (y/N)');
    │                           ^^^^^^^
    ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/galileo_prompts.dart

WARNING: The operand can't be null, so the condition is always 'true'.

lib/galileo_prompts.dart:179:26

    ╷
179 │       return (defaultsTo != null && s.isEmpty) || s.startsWith('y') || s.startsWith('n');
    │                          ^^^^^^^
    ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/galileo_prompts.dart

OK
Support up-to-date dependencies
20 / 20trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
charcode ^1.2.0 1.3.1 1.3.1
io ^1.0.0 1.0.4 1.0.4
Transitive dependencies
Package Constraint Compatible Latest
collection - 1.18.0 1.18.0
meta - 1.14.0 1.14.0
path - 1.9.0 1.9.0
source_span - 1.10.0 1.10.0
string_scanner - 1.2.0 1.2.0
term_glyph - 1.2.1 1.2.1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.3, Dart 3.3.3.

Check the analysis log for details.

0
likes
120
pub points
0%
popularity

Publisher

verified publishergalileodart.com

Rich, simple, synchronous command-line prompt library for Dart.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

charcode, io

More

Packages that depend on galileo_prompts