galileo_mustache4dart 3.0.0 icon indicating copy to clipboard operation
galileo_mustache4dart: ^3.0.0 copied to clipboard

A mustache implementation for the Dart language

1
likes
45/ 130
pub points
17%
popularity

We analyzed this package 23 hours ago, and awarded it 45 pub points (of a possible 130):

icon indicating section status
Follow Dart file conventions
5 / 20icon to trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

0/5 points: Provide a valid README.md

Links in `README.md` should be secure. 5 links are insecure.

README.md:4:31

  ╷
4 │ <p>A simple implementation of <a href="http://mustache.github.com/">Mustache</a> for the
  │                               ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

Use https URLs instead.

5/5 points: Provide a valid CHANGELOG.md

icon indicating section status
Provide documentation
0 / 20icon to trigger folding of the section

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

0/10 points: 20% or more of the public API has dartdoc comments

  • 4 out of 55 API elements (7.3 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

icon indicating section status
Platform Support
0 / 20icon to trigger folding of the section

0/20 points: Supports 0 of 6 possible platforms (iOS, Android, Web, Windows, MacOS, Linux)

These platforms are not supported:

Package not compatible with platform Android

Because:

  • package:galileo_mustache4dart/galileo_mustache4dart.dart that imports:
  • package:galileo_mustache4dart/mustache_context.dart that imports:
  • package:galileo_mustache4dart/src/mirrors.dart that imports:
  • dart:mirrors
Package not compatible with platform iOS

Because:

  • package:galileo_mustache4dart/galileo_mustache4dart.dart that imports:
  • package:galileo_mustache4dart/mustache_context.dart that imports:
  • package:galileo_mustache4dart/src/mirrors.dart that imports:
  • dart:mirrors
Package not compatible with platform Windows

Because:

  • package:galileo_mustache4dart/galileo_mustache4dart.dart that imports:
  • package:galileo_mustache4dart/mustache_context.dart that imports:
  • package:galileo_mustache4dart/src/mirrors.dart that imports:
  • dart:mirrors
Package not compatible with platform Linux

Because:

  • package:galileo_mustache4dart/galileo_mustache4dart.dart that imports:
  • package:galileo_mustache4dart/mustache_context.dart that imports:
  • package:galileo_mustache4dart/src/mirrors.dart that imports:
  • dart:mirrors
Package not compatible with platform macOS

Because:

  • package:galileo_mustache4dart/galileo_mustache4dart.dart that imports:
  • package:galileo_mustache4dart/mustache_context.dart that imports:
  • package:galileo_mustache4dart/src/mirrors.dart that imports:
  • dart:mirrors
Package not compatible with platform Web

Because:

  • package:galileo_mustache4dart/galileo_mustache4dart.dart that imports:
  • package:galileo_mustache4dart/mustache_context.dart that imports:
  • package:galileo_mustache4dart/src/mirrors.dart that imports:
  • dart:mirrors
icon indicating section status
Pass static analysis
20 / 30icon to trigger folding of the section

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 5 issues. Showing the first 2:

lib/galileo_mustache4dart.dart doesn't match the Dart formatter.

To format your files run: dart format .

lib/mustache_context.dart doesn't match the Dart formatter.

To format your files run: dart format .

icon indicating section status
Support up-to-date dependencies
20 / 20icon to trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

No dependencies.

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

icon indicating section status
Support sound null safety
0 / 20icon to trigger folding of the section

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.10.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.21.5, Dart 2.15.1.