g_faraday 1.0.0 copy "g_faraday: ^1.0.0" to clipboard
g_faraday: ^1.0.0 copied to clipboard

A very simple plugin for building hybrid stack apps with flutter

10
likes
150/ 160
pub points
29%
popularity

We analyzed this package 4 days ago, and awarded it 150 pub points (of a possible 160):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

57 out of 91 API elements (62.6 %) have documentation comments.

Some symbols that are missing documentation: g_faraday, g_faraday.FaradayCommon, g_faraday.FaradayCommon.FaradayCommon, g_faraday.FaradayCommon.invokeListMethod, g_faraday.FaradayCommon.invokeMapMethod.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 2 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS

These platforms are not supported:

Package does not support platform `Windows`.

Because:

  • package:g_faraday/g_faraday.dart that declares support for platforms: Android, iOS.
Package does not support platform `Linux`.

Because:

  • package:g_faraday/g_faraday.dart that declares support for platforms: Android, iOS.
Package does not support platform `macOS`.

Because:

  • package:g_faraday/g_faraday.dart that declares support for platforms: Android, iOS.
Package does not support platform `Web`.

Because:

  • package:g_faraday/g_faraday.dart that declares support for platforms: Android, iOS.
partial
Pass static analysis
40 / 50trigger folding of the section

40/50 points: code has no errors, warnings, lints, or formatting issues

INFO: 'hasScopedWillPopCallback' is deprecated and shouldn't be used. Use popDisposition instead. This feature was deprecated after v3.12.0-1.0.pre.

lib/src/route/observer.dart:73:19

   ╷
73 │             route.hasScopedWillPopCallback || !onlyOnePage;
   │                   ^^^^^^^^^^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/route/observer.dart

lib/src/widgets/debugger.dart doesn't match the Dart formatter.

To format your files run: dart format .

OK
Support up-to-date dependencies
40 / 40trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
flutter flutter 0.0.0 0.0.0
g_json ^4.1.0 4.1.0 4.1.0
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
collection - 1.18.0 1.19.0
material_color_utilities - 0.8.0 0.12.0
meta - 1.12.0 1.15.0
sky_engine - 0.0.99 0.0.99
vector_math - 2.1.4 2.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

20/20 points: Compatible with dependency constraint lower bounds

pub downgrade does not expose any static analysis error.

Analyzed with Pana 0.22.6, Flutter 3.22.2, Dart 3.4.3.

Check the analysis log for details.

10
likes
150
pub points
29%
popularity

Publisher

verified publisherfaraday.icu

A very simple plugin for building hybrid stack apps with flutter

Repository (GitHub)
View/report issues
Contributing

Documentation

API reference

License

MIT (LICENSE)

Dependencies

flutter, g_json

More

Packages that depend on g_faraday