fxendit 0.0.3 copy "fxendit: ^0.0.3" to clipboard
fxendit: ^0.0.3 copied to clipboard

PlatformAndroid

The easy way to use Xendit Software Development Kit (SDK) in Flutter.

11
likes
120/ 140
pub points
41%
popularity

We analyzed this package 30 hours ago, and awarded it 120 pub points (of a possible 140):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

112 out of 123 API elements (91.1 %) have documentation comments.

Some symbols that are missing documentation: fxendit, fxendit.AMEX, fxendit.CardType.cardKey, fxendit.CardType.cardName, fxendit.DANKORT.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 1 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android

These platforms are not supported:

Package does not support platform `iOS`.

Because:

  • package:fxendit/fxendit.dart that declares support for platforms: Android.
Package does not support platform `Windows`.

Because:

  • package:fxendit/fxendit.dart that declares support for platforms: Android.
Package does not support platform `Linux`.

Because:

  • package:fxendit/fxendit.dart that declares support for platforms: Android.
Package does not support platform `macOS`.

Because:

  • package:fxendit/fxendit.dart that declares support for platforms: Android.
Package does not support platform `Web`.

Because:

  • package:fxendit/fxendit.dart that declares support for platforms: Android.
partial
Pass static analysis
40 / 50trigger folding of the section

40/50 points: code has no errors, warnings, lints, or formatting issues

INFO: The file name '3ds_recommendation.dart' isn't a lower_case_with_underscores identifier.

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/models/3ds_recommendation.dart

failed
Support up-to-date dependencies
10 / 20trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
flutter flutter 0.0.0 0.0.0
intl ^0.17.0 0.17.0 0.19.0
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
clock - 1.1.1 1.1.1
collection - 1.18.0 1.18.0
material_color_utilities - 0.8.0 0.8.0
meta - 1.11.0 1.12.0
path - 1.9.0 1.9.0
sky_engine - 0.0.99 0.0.99
vector_math - 2.1.4 2.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.17.0` on intl does not support the stable version `0.18.0`.

Try running dart pub upgrade --major-versions intl to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.2, Flutter 3.19.1, Dart 3.3.0.

Check the analysis log for details.

11
likes
120
pub points
41%
popularity

Publisher

unverified uploader

The easy way to use Xendit Software Development Kit (SDK) in Flutter.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

flutter, intl

More

Packages that depend on fxendit