future_or 0.1.0

  • Readme
  • Changelog
  • Installing
  • new56

future_or #

A collection of widgets, methods and extension methods that make working with FutureOr objects easier

Extension method #

Getters #

  1. isFuture : true if future
  2. isNotFuture : true if value
  3. value : casts to a value
  4. future : casts to a future
  5. asFuture : if not a future, returns Future.value of the value

FutureOrBuilder #

if the futureOr is a value, calls the builder with the value. if the futureOr is a future, return a FutureBuilder widget.

[0.1.0]

  • added FutureOrBuilder based on FutureBuilder
  • added isFuture extension getter
  • added isNotFuture extension getter
  • added value extension getter
  • added future extension getter
  • added asFutureextension getter

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  future_or: ^0.1.0

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:future_or/future_or.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
16
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
90
Overall:
Weighted score of the above. [more]
56
Learn more about scoring.

We analyzed this package on Jan 19, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.7.0
  • pana: 0.13.4
  • Flutter: 1.12.13+hotfix.5

Maintenance suggestions

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and future_or.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.7.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.11 1.14.12
meta 1.1.8
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8