fusion_auth 1.0.3 copy "fusion_auth: ^1.0.3" to clipboard
fusion_auth: ^1.0.3 copied to clipboard

This is a plug-in for one click login in the alicloud fusion authentication service. Alibaba cloud is also used in the one click login function

2
likes
135/ 160
pub points
26%
popularity

We analyzed this package 2 days ago, and awarded it 135 pub points (of a possible 160):

failed
Follow Dart file conventions
25 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

Issue tracker URL doesn't exist.

At the time of the analysis https://github.com/CodeGather/fusion_auth/issues was unreachable. Make sure that the website is reachable via HEAD requests.

5/5 points: Provide a valid README.md

0/5 points: Provide a valid CHANGELOG.md

`CHANGELOG.md` contains too many non-ASCII characters.

The site uses English as its primary language. The content of CHANGELOG.md in your package should primarily contain characters used in English.

10/10 points: Use an OSI-approved license

Detected license: Apache-2.0.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

65 out of 133 API elements (48.9 %) have documentation comments.

Some symbols that are missing documentation: fusion_auth, fusion_auth.AuthResultCode, fusion_auth.AuthResultCode.code, fusion_auth.AuthResultCode.message, fusion_auth.CustomThirdView.bottom.

10/10 points: Package has an example and has no issues with screenshots

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 2 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS

These platforms are not supported:

Package does not support platform `Windows`.

Because:

  • package:fusion_auth/fusion_auth.dart that declares support for platforms: Android, iOS.
Package does not support platform `Linux`.

Because:

  • package:fusion_auth/fusion_auth.dart that declares support for platforms: Android, iOS.
Package does not support platform `macOS`.

Because:

  • package:fusion_auth/fusion_auth.dart that declares support for platforms: Android, iOS.
Package does not support platform `Web`.

Because:

  • package:fusion_auth/fusion_auth.dart that declares support for platforms: Android, iOS.
partial
Pass static analysis
40 / 50trigger folding of the section

40/50 points: code has no errors, warnings, lints, or formatting issues

Found 5 issues. Showing the first 2:

INFO: The declaration '_$AlertUIConfigToJson' isn't referenced.

lib/src/config/alert_ui_config.g.dart:51:22

   ╷
51 │ Map<String, dynamic> _$AlertUIConfigToJson(AlertUIConfig instance) =>
   │                      ^^^^^^^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/config/alert_ui_config.g.dart

INFO: The declaration '_$DialogUIConfigToJson' isn't referenced.

lib/src/config/dialog_ui_config.g.dart:51:22

   ╷
51 │ Map<String, dynamic> _$DialogUIConfigToJson(DialogUIConfig instance) =>
   │                      ^^^^^^^^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/config/dialog_ui_config.g.dart

failed
Support up-to-date dependencies
30 / 40trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
flutter flutter 0.0.0 0.0.0
flutter_localizations flutter 0.0.0 0.0.0
json_annotation >=4.8.1 <4.9.0 4.8.1 4.9.0
plugin_platform_interface ^2.0.2 2.1.8 2.1.8
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
clock - 1.1.1 1.1.1
collection - 1.18.0 1.19.0
intl - 0.19.0 0.19.0
material_color_utilities - 0.8.0 0.12.0
meta - 1.12.0 1.15.0
path - 1.9.0 1.9.0
sky_engine - 0.0.99 0.0.99
vector_math - 2.1.4 2.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `>=4.8.1 <4.9.0` on json_annotation does not support the stable version `4.9.0`.

Try running dart pub upgrade --major-versions json_annotation to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

20/20 points: Compatible with dependency constraint lower bounds

pub downgrade does not expose any static analysis error.

Analyzed with Pana 0.22.9, Flutter 3.22.2, Dart 3.4.3.

Check the analysis log for details.

2
likes
135
pub points
26%
popularity
screenshot

Publisher

verified publisherki5k.com

This is a plug-in for one click login in the alicloud fusion authentication service. Alibaba cloud is also used in the one click login function

Repository (GitHub)
View/report issues
Contributing

Topics

#aliyun #phone #sms #idcode #fusion

Documentation

API reference

License

Apache-2.0 (license)

Dependencies

flutter, flutter_localizations, json_annotation, plugin_platform_interface

More

Packages that depend on fusion_auth