fullauth_api_flutter_client 1.0.3
fullauth_api_flutter_client: ^1.0.3 copied to clipboard

Flutter Android iOS Linux macOS Windows

Provides api interface for flutter clients.

0
likes
50 / 110
pub points
0 %
popularity

We analyzed this package on Feb 27, 2021, and awarded it 50 pub points (of a possible 110):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

Homepage URL doesn't exist.

At the time of the analysis https://github.com/karthikAdaptavant/fullauth_api_flutter_client.git was unreachable.

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
0 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

0/10 points: 20% or more of the public API has dartdoc comments

  • 6 out of 205 API elements (2.9 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Consider supporting multiple platforms:

Package not compatible with runtime flutter-web on Web

Because:

  • package:fullauth_api_flutter_client/fullauth_api_flutter_client_library.dart that imports:
  • dart:io
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 30 issues. Showing the first 2:

INFO: This function has a return type of 'String', but doesn't end with a return statement.

lib/enums/auth_environment.dart:6:14

  ╷
6 │   String get authDomain {
  │              ^^^^^^^^^^
  ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/enums/auth_environment.dart

INFO: This function has a return type of 'String', but doesn't end with a return statement.

lib/enums/auth_environment.dart:17:10

   ╷
17 │   String getAuthUrl(String domain) {
   │          ^^^^^^^^^^
   ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/enums/auth_environment.dart

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
flutterflutter0.0.00.0.0
http^0.12.0+40.12.20.13.0
optional^3.1.03.1.05.0.0+1
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.0-nullsafety.31.1.0
charcode-1.1.31.2.0
collection-1.15.0-nullsafety.31.15.0
http_parser-3.1.44.0.0
meta-1.3.0-nullsafety.31.3.0
path-1.7.01.8.0
pedantic-1.9.21.10.0
sky_engine-0.0.990.0.99
source_span-1.7.01.8.1
string_scanner-1.0.51.1.0
term_glyph-1.1.01.2.0
typed_data-1.3.0-nullsafety.31.3.0
vector_math-2.1.0-nullsafety.32.1.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.12.0+4` on http does not support the latest published version `0.13.0`

pubspec.yaml:14:9

   ╷
14 │   http: ^0.12.0+4
   │         ^^^^^^^^^
   ╵
The constraint `^3.1.0` on optional does not support the latest published version `5.0.0+1`

pubspec.yaml:15:13

   ╷
15 │   optional: ^3.1.0 
   │             ^^^^^^
   ╵

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analysed with Pana 0.14.10, Flutter 1.22.6, Dart 2.10.5.

0
likes
50
pub points
0%
popularity

Provides api interface for flutter clients.

Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

karthik.samy@anywhere.co

License

unknown (LICENSE)

Dependencies

flutter, http, optional

More

Packages that depend on fullauth_api_flutter_client