ftpconnect 0.2.1
ftpconnect: ^0.2.1 copied to clipboard

Dart native
Flutter Android iOS Linux macOS Windows

Flutter simple and robust dart FTP Connect Library to interact with FTP Servers with possibility of zip and unzip files.

24
likes
90 / 110
pub points
83 %
popularity

We analyzed this package on Mar 1, 2021, and awarded it 90 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 26 out of 59 API elements (44.1 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:ftpconnect/ftpconnect.dart that imports:
  • package:ftpconnect/src/ftpclient_base.dart that imports:
  • package:ftpconnect/src/ftpSocket.dart that imports:
  • dart:io
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 20 issues. Showing the first 2:

INFO: DO use curly braces for all flow control structures.

lib/src/dto/FTPEntry.dart:52:7

   ╷
52 │       return FTPEntry._parseListCommand(responseLine);
   │       ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/src/dto/FTPEntry.dart

INFO: DO use curly braces for all flow control structures.

lib/src/dto/FTPEntry.dart:54:7

   ╷
54 │ ┌       return FTPEntry._(responseLine, null, null, null, null, null, null, null,
55 │ └           null, null, null, null);
   ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/src/dto/FTPEntry.dart

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
archive^2.0.132.0.133.1.1
intl^0.16.10.16.10.17.0
path^1.7.01.7.01.8.0
Transitive dependencies
PackageConstraintCompatibleLatest
args-1.6.02.0.0
charcode-1.1.31.2.0
collection-1.14.131.15.0
convert-2.1.13.0.0
crypto-2.1.53.0.0
typed_data-1.2.01.3.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^2.0.13` on archive does not support the stable version `3.0.0`, that was published 25 days ago.

When archive is 30 days old, this package will no longer be awarded points in this category.

Try running dart pub upgrade --major-versions archive to update the constraint.

The constraint `^0.16.1` on intl does not support the stable version `0.17.0`, that was published 25 days ago.

When intl is 30 days old, this package will no longer be awarded points in this category.

Try running dart pub upgrade --major-versions intl to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analysed with Pana 0.15.1+1, Dart 2.10.5.

24
likes
90
pub points
83%
popularity

Flutter simple and robust dart FTP Connect Library to interact with FTP Servers with possibility of zip and unzip files.

Homepage
Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

salim.lachdhaf@gmail.com

License

MIT (LICENSE)

Dependencies

archive, intl, path

More

Packages that depend on ftpconnect