ftl 1.0.0-alpha.1

dart_ftl #

Dart parser for the Project Fluent FTL file format.

Getting Started #

This project is a starting point for a Dart package, a library module containing code that can be shared easily across multiple Flutter or Dart projects.

Changelog #

1.0.0-alpha.1 (December 6, 2019) #

First alpha release of dart_ftl -- the Fluent Project file parser. At this point, the parser successfully parses all the test cases from the original Project Fluent (https://projectfluent.org/) fixtures, which are included in the testdata directory.

The AST included will most likely change based on actual uses of the library, bug reports, and contributions. It should not be considered stable at this point.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  ftl: ^1.0.0-alpha.1

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter pub get

Alternatively, your editor might support pub get or flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:ftl/ftl.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
98
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
66
Overall:
Weighted score of the above. [more]
43
Learn more about scoring.

We analyzed this package on Feb 13, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.7.1
  • pana: 0.13.5

Health issues and suggestions

Document public APIs. (-1 points)

115 out of 115 API elements have no dartdoc comment.Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API.

Fix lib/src/ast.dart. (-1 points)

Analysis of lib/src/ast.dart reported 2 hints:

line 138 col 24: Don't type annotate initializing formals.

line 138 col 67: Don't type annotate initializing formals.

Format lib/src/parser.dart.

Run dartfmt to format lib/src/parser.dart.

Maintenance issues and suggestions

Support latest dependencies. (-10 points)

The version constraint in pubspec.yaml does not support the latest published versions for 1 dependency (petitparser).

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and ftl.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

The package description is too short. (-9 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Package is pre-release. (-5 points)

Pre-release versions should be used with caution; their API can change in breaking ways.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.3.0 <3.0.0
petitparser ^2.4.0 2.4.0 3.0.1
Transitive dependencies
meta 1.1.8
Dev dependencies
test ^1.9.4