framy_generator 0.3.3 icon indicating copy to clipboard operation
framy_generator: ^0.3.3 copied to clipboard

A convenient code generator for app styleguide, gallery, storyboard and more.

39
likes
40/ 140
pub points
5%
popularity

We analyzed this package 7 days ago, and awarded it 40 pub points (of a possible 140):

icon indicating section status
Follow Dart file conventions
30 / 30icon to trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: LGPL-3.0.

icon indicating section status
Provide documentation
10 / 20icon to trigger folding of the section

0/10 points: 20% or more of the public API has dartdoc comments

Dependency resultion failed, unable to run dartdoc.

10/10 points: Package has an example

icon indicating section status
Platform support
0 / 20icon to trigger folding of the section

0/20 points: Platform support detection failed

Could not determine supported platforms as package resolution failed.

Run dart pub get for more information.

icon indicating section status
Pass static analysis
0 / 50icon to trigger folding of the section

0/50 points: code has no errors, warnings, lints, or formatting issues

  • Running dart pub outdated failed with the following output:
The lower bound of "sdk: '>=2.7.0 <3.0.0'" must be 2.12.0'
or higher to enable null safety.
icon indicating section status
Support up-to-date dependencies
0 / 20icon to trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Sdk constraint doesn't support current Dart version 3.3.0-166.0.dev. Cannot run `dart pub outdated`.

pubspec.yaml:8:8

  ╷
8 │   sdk: ">=2.7.0 <3.0.0"
  │        ^^^^^^^^^^^^^^^^
  ╵

0/10 points: Package supports latest stable Dart and Flutter SDKs

Sdk constraint doesn't support current Dart version 3.3.0-166.0.dev.

pubspec.yaml:8:8

  ╷
8 │   sdk: ">=2.7.0 <3.0.0"
  │        ^^^^^^^^^^^^^^^^
  ╵

Try widening the upper boundary of the constraint.

Analyzed with Pana 0.21.43, Dart 3.3.0-166.0.dev.

Check the analysis log for details.

39
likes
40
pub points
5%
popularity

Publisher

verified publisher iconfidev.io

A convenient code generator for app styleguide, gallery, storyboard and more.

Homepage
Repository (GitHub)
View/report issues

License

Icon for licenses.LGPL-3.0 (LICENSE)

Dependencies

analyzer, build, framy_annotation, glob, pedantic, source_gen, yaml

More

Packages that depend on framy_generator