fpm 0.3.0

  • Readme
  • Changelog
  • Installing
  • new50

Flutter Package Manager #

Flutter Package Manager, powerfull package management via CLI, add/search/top/favorite packages!

Install #

> pub global activate fpm

Usage #

Without verbose

$ fpm top
$ fpm favorites
$ fpm search html
$ fpm search html --verbose
# Install a specific version
$ fpm add http

# Install to dev_dependencies
$ fpm add --dev http
❯ fpm --help     
Flutter Version Management: A cli to manage Flutter packages.

Usage: fpm <command> [arguments]

Global options:
-h, --help       Print this usage information.
    --verbose    Print verbose output.

Available commands:
  add         Add package SDK Version
  favorites   List of the flutter favorite packages
  search      Search dart packages
  top         List the top used dart packages

Run "fpm help <command>" for more information about a command.

0.3.0 #

  • several fixes

0.2.0 #

  • several fixes

0.1.0 #

  • Initial version

Use this package as an executable

1. Install it

You can install the package from the command line:


$ pub global activate fpm

2. Use it

The package has the following executables:


$ fpm

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  fpm: ^0.3.0

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter pub get

Alternatively, your editor might support pub get or flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:fpm/commands/add.dart';
import 'package:fpm/commands/favorites.dart';
import 'package:fpm/commands/search.dart';
import 'package:fpm/commands/top.dart';
import 'package:fpm/package.dart';
import 'package:fpm/parser.dart';
import 'package:fpm/pretty.printer.dart';
import 'package:fpm/utils/runner.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
100
Overall:
Weighted score of the above. [more]
50
Learn more about scoring.

We analyzed this package on Jul 8, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.8.4
  • pana: 0.13.13

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.8.1 <3.0.0
ansicolor ^1.0.2 1.0.2
args ^1.6.0 1.6.0
cli_util ^0.2.0 0.2.0
console ^3.1.0 3.1.0
html ^0.14.0+3 0.14.0+3
http ^0.12.1 0.12.1
path ^1.7.0 1.7.0
Transitive dependencies
charcode 1.1.3
collection 1.14.13 1.15.0-nnbd
csslib 0.16.1
http_parser 3.1.4
meta 1.2.1
source_span 1.7.0
string_scanner 1.0.5
term_glyph 1.1.0
typed_data 1.2.0 1.3.0-nnbd
vector_math 2.0.8 2.1.0-nullsafety
Dev dependencies
pedantic ^1.9.0 1.9.1
test ^1.14.4