fpdt 0.1.4 copy "fpdt: ^0.1.4" to clipboard
fpdt: ^0.1.4 copied to clipboard

A collection of functions and monads for functional programming in dart.

4
likes
90/ 140
pub points
25%
popularity

We analyzed this package 39 hours ago, and awarded it 90 pub points (of a possible 140):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

1196 out of 1632 API elements (73.3 %) have documentation comments.

Some symbols that are missing documentation: either, either.Do, either.DoFunction, either.Left, either.Left.Left.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS
  • ✓ Web
failed
Pass static analysis
0 / 50trigger folding of the section

0/50 points: code has no errors, warnings, lints, or formatting issues

Found 83 issues. Showing the first 2:

ERROR: The name 'Tuple2' isn't a type, so it can't be used as a type argument.

lib/either.dart:127:11

    ╷
127 │ Either<L, Tuple2<R, R2>> Function(Either<L, R> either) flatMapTuple2<L, R, R2>(
    │           ^^^^^^
    ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/either.dart

ERROR: The name 'Tuple2' isn't a type, so it can't be used as a type argument.

lib/either.dart:133:49

    ╷
133 │ Either<L, Tuple3<R, R2, R3>> Function(Either<L, Tuple2<R, R2>> either)
    │                                                 ^^^^^^
    ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/either.dart

OK
Support up-to-date dependencies
20 / 20trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
fast_immutable_collections any 10.2.3 10.2.3
Transitive dependencies
Package Constraint Compatible Latest
collection - 1.18.0 1.18.0
meta - 1.15.0 1.15.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.3, Dart 3.4.0.

Check the analysis log for details.

4
likes
90
pub points
25%
popularity

Publisher

verified publishertimsmart.co

A collection of functions and monads for functional programming in dart.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

fast_immutable_collections

More

Packages that depend on fpdt