formini 0.0.1-alpha.1

Flutter Android iOS web

Simple yet powerful form state management

0
likes
60 / 110
pub points
35 %
popularity

We analyzed this package on Oct 31, 2020, and awarded it 60 pub points (of a possible 110):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
0 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

0/10 points: 20% or more of the public API has dartdoc comments

  • 5 out of 53 API elements (9.4 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
20 / 20

20/20 points: Supports 3 of 3 possible platforms (iOS, Android, Web)

Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

lib/src/bloc/errors.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

lib/src/builders/state_builder.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
bloc^0.15.00.15.06.1.0
flutterflutter0.0.00.0.0
flutter_bloc^0.21.00.21.06.0.6
rxdart^0.22.20.22.60.24.1
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.0-nullsafety.31.1.0-nullsafety.4
collection-1.15.0-nullsafety.31.15.0-nullsafety.4
meta-1.3.0-nullsafety.31.3.0-nullsafety.5
provider-3.2.04.3.2+2
sky_engine-0.0.990.0.99
typed_data-1.3.0-nullsafety.31.3.0-nullsafety.4
vector_math-2.1.0-nullsafety.32.1.0-nullsafety.4

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 3 issues. Showing the first 2:

The constraint `^0.15.0` on bloc does not support the latest published version `6.1.0`

pubspec.yaml:13:9

   ╷
13 │   bloc: ^0.15.0
   │         ^^^^^^^
   ╵
The constraint `^0.21.0` on flutter_bloc does not support the latest published version `6.0.6`

pubspec.yaml:14:17

   ╷
14 │   flutter_bloc: ^0.21.0
   │                 ^^^^^^^
   ╵

10/10 points: Package supports latest stable Dart and Flutter SDKs

0
likes
60
pub points
35%
popularity

Simple yet powerful form state management

Homepage

Documentation

API reference

Uploader

jari@vantage.fi

License

MIT (LICENSE)

Dependencies

bloc, flutter, flutter_bloc, rxdart

More

Packages that depend on formini