form_field_validator 1.1.0 copy "form_field_validator: ^1.1.0" to clipboard
form_field_validator: ^1.1.0 copied to clipboard

A straightforward flutter form field validator that provides common validation options.

438
likes
140/ 160
pub points
98%
popularity

We analyzed this package 16 hours ago, and awarded it 140 pub points (of a possible 160):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

18 out of 57 API elements (31.6 %) have documentation comments.

Some symbols that are missing documentation: form_field_validator, form_field_validator.DateValidator, form_field_validator.DateValidator.DateValidator, form_field_validator.DateValidator.format, form_field_validator.EmailValidator.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS
  • ✓ Web
failed
Pass static analysis
30 / 50trigger folding of the section

30/50 points: code has no errors, warnings, lints, or formatting issues

WARNING: Unused import: 'package:flutter/foundation.dart'.

lib/form_field_validator.dart:3:8

  ╷
3 │ import 'package:flutter/foundation.dart';
  │        ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/form_field_validator.dart

INFO: Using a colon as the separator before a default value is deprecated and will not be supported in language version 3.0 and later.

lib/form_field_validator.dart:38:66

   ╷
38 │   bool hasMatch(String pattern, String input, {bool caseSensitive: true}) =>
   │                                                                  ^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/form_field_validator.dart

OK
Support up-to-date dependencies
40 / 40trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
flutter flutter 0.0.0 0.0.0
intl >=0.17.0 <=1.0.0 0.19.0 0.19.0
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
clock - 1.1.1 1.1.1
collection - 1.18.0 1.19.0
material_color_utilities - 0.8.0 0.12.0
meta - 1.12.0 1.15.0
path - 1.9.0 1.9.0
sky_engine - 0.0.99 0.0.99
vector_math - 2.1.4 2.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

20/20 points: Compatible with dependency constraint lower bounds

pub downgrade does not expose any static analysis error.

Analyzed with Pana 0.22.9, Flutter 3.22.2, Dart 3.4.3.

Check the analysis log for details.

438
likes
140
pub points
98%
popularity

Publisher

verified publishercodeness.ly

A straightforward flutter form field validator that provides common validation options.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (license)

Dependencies

flutter, intl

More

Packages that depend on form_field_validator