form_builder_map_field 0.0.1
form_builder_map_field: ^0.0.1 copied to clipboard

Map Input Field for flutter_form_builder package. Used to select coodinates on a map.

8
likes
80 / 130
pub points
74 %
popularity

We analyzed this package on Jul 28, 2021, and awarded it 80 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

0/10 points: 20% or more of the public API has dartdoc comments

  • 1 out of 39 API elements (2.6 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Found 6 issues. Showing the first 2:

Consider supporting multiple platforms:

Package does not support Flutter platform Web

Because:

  • package:form_builder_map_field/form_builder_map_field.dart that imports:
  • package:google_maps_flutter/google_maps_flutter.dart that declares support for platforms: Android, iOS
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
flutterflutter0.0.00.0.0
flutter_form_builder^3.8.13.14.16.0.1
google_maps_flutter^0.5.25+10.5.332.0.6
Transitive dependencies
PackageConstraintCompatibleLatest
archive-2.0.133.1.2
args-1.6.02.2.0
basic_utils-2.7.13.3.3
characters-1.1.01.1.0
charcode-1.3.11.3.1
collection-1.15.01.15.0
convert-2.1.13.0.1
country_pickers-1.3.02.0.0
crypto-2.1.53.0.1
date_range_picker-1.0.71.0.7
datetime_picker_formfield-1.0.02.0.0
flutter_chips_input-1.10.01.10.0
flutter_colorpicker-0.3.50.5.0
flutter_keyboard_visibility-4.0.65.0.3
flutter_keyboard_visibility_platform_interface-1.0.12.0.0
flutter_keyboard_visibility_web-1.0.12.0.0
flutter_plugin_android_lifecycle-1.0.112.0.2
flutter_touch_spin-1.0.11.0.1
flutter_typeahead-1.9.33.2.0
flutter_web_plugins-0.0.00.0.0
google_maps_flutter_platform_interface-1.2.02.1.0
http-0.12.20.13.3
http_parser-3.1.44.0.0
image-2.1.193.0.2
image_picker-0.6.7+220.8.2
image_picker_for_web-0.1.0+22.1.2
image_picker_platform_interface-1.1.62.2.0
intl-0.16.10.17.0
js-0.6.30.6.3
json_annotation-3.1.14.1.0
logging-0.11.41.0.1
meta-1.3.01.7.0
path-1.8.01.8.0
pedantic-1.11.11.11.1
petitparser-3.1.04.2.0
phone_number-0.6.30.11.0+1
plugin_platform_interface-1.0.32.0.1
pointycastle-2.0.13.1.3
random_string-2.3.12.3.1
rating_bar-0.2.00.2.0
signature-3.2.14.1.1
sky_engine-0.0.990.0.99
source_span-1.8.11.8.1
stream_transform-1.2.02.0.0
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0
validators-2.0.13.0.0
vector_math-2.1.02.1.0
vin_decoder-0.1.30.1.4+1
xml-4.5.15.1.2

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^3.8.1` on flutter_form_builder does not support the stable version `4.0.0`.

Try running dart pub upgrade --major-versions flutter_form_builder to update the constraint.

The constraint `^0.5.25+1` on google_maps_flutter does not support the stable version `1.0.0`.

Try running dart pub upgrade --major-versions google_maps_flutter to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.1.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.19.0, Flutter 2.2.3, Dart 2.13.4.

8
likes
80
pub points
74%
popularity

Publisher

danvickmiller.dev

Map Input Field for flutter_form_builder package. Used to select coodinates on a map.

Repository (GitHub)
View/report issues

Documentation

API reference

License

BSD (LICENSE)

Dependencies

flutter, flutter_form_builder, google_maps_flutter

More

Packages that depend on form_builder_map_field