form 0.0.5

  • Readme
  • Changelog
  • Example
  • Installing
  • 70

Form #

A simple and powerful way to manipulate flutter forms. 🚀⚡

Build Status Coverage Status Pub Version License

Documentation #

Change log #

See CHANGELOG for more information on what has changed recently.

Contributing #

Submit feature requests and errors on the issue tracker.

Credits #

License #

The MIT License. See License file for more information.

[0.0.5] - July 05, 2020 #

  • Added TextEditingController support.
  • Added initValue
  • Added form model binding

[0.0.4] - May 24, 2020 #

  • Added InputText widget.

[0.0.3+2] - May 14, 2020 #

  • Updated documentation.

[0.0.3+1] - May 13, 2020 #

  • Fix pub.dev issues.

[0.0.3] - May 13, 2020 #

  • Changed many items of the API.

[0.0.2] - May 11, 2020 #

  • Changed many items of the API.

[0.0.1] - May 10, 2020 #

  • First beta version.

example/lib/main.dart

import 'package:example/app.dart';
import 'package:example/controllers/auth_controller.dart';
import 'package:flutter/material.dart';
import 'package:provider/provider.dart';

void main() {
  runApp(
    Provider(
      create: (_) => AuthController(),
      child: App(),
    ),
  );
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  form: ^0.0.5

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:form/form.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
45
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
90
Overall:
Weighted score of the above. [more]
70
Learn more about scoring.

We analyzed this package on Jul 8, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.8.4
  • pana: 0.13.14
  • Flutter: 1.17.5

Analysis suggestions

Package not compatible with SDK dart

Because:

  • form that is a package requiring null.

Health suggestions

Fix lib/src/form.dart. (-0.50 points)

Analysis of lib/src/form.dart reported 1 hint:

line 707 col 29: 'isValid' is deprecated and shouldn't be used. Use validate method instaed..

Maintenance suggestions

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.7.0 <3.0.0
flutter 0.0.0
validators ^2.0.0+1 2.0.1
Transitive dependencies
asn1lib 0.6.5
basic_utils 2.5.5
charcode 1.1.3
collection 1.14.12 1.14.13
convert 2.1.1
crypto 2.1.5
http 0.12.1
http_parser 3.1.4
intl 0.16.1
json_annotation 3.0.1
logging 0.11.4
meta 1.1.8 1.2.1
path 1.7.0
pedantic 1.9.0 1.9.1
pointycastle 1.0.2
random_string 2.1.0
sky_engine 0.0.99
source_span 1.7.0
string_scanner 1.0.5
term_glyph 1.1.0
typed_data 1.1.6 1.2.0
vector_math 2.0.8 2.1.0-nullsafety
vin_decoder 0.1.2
Dev dependencies
flutter_test