font_awesome_flutter 7.1.0 copy "font_awesome_flutter: ^7.1.0" to clipboard
font_awesome_flutter: ^7.1.0 copied to clipboard

outdatedDart 1 only

The Font Awesome Icon pack available as Flutter Icons

4339
likes
15/ 160
pub points
100%
popularity

We analyzed this package 4 days ago, and awarded it 15 pub points (of a possible 160):

failed
Follow Dart file conventions
5 / 30trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Failed to verify repository URL.

Please provide a valid repository URL in pubspec.yaml, such that:

  • repository can be cloned,
  • a clone of the repository contains a pubspec.yaml, which:,
    • contains name: font_awesome_flutter,
    • contains a version property, and,
    • does not contain a publish_to property.

pubspec.yaml from the repository URL mismatch: expected https://github.com/brianegan/font_awesome_flutter but got https://github.com/fluttercommunity/font_awesome_flutter.

0/5 points: Provide a valid README.md

Links in `README.md` should be secure. 1 link is insecure.

README.md:2:8

  ╷
2 │ <p>The <a href="http://fontawesome.io/icons/">Font Awesome</a> Icon pack available as set of Flutter Icons.</p>
  │        ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

Use https URLs instead.

5/5 points: Provide a valid CHANGELOG.md

0/10 points: Use an OSI-approved license

No license was recognized.

Consider using an OSI-approved license in the LICENSE file to make it more accessible to the community.

failed
Provide documentation
10 / 20trigger folding of the section

0/10 points: 20% or more of the public API has dartdoc comments

Dependency resolution failed, unable to run dartdoc.

10/10 points: Package has an example

failed
Platform support
0 / 20trigger folding of the section

0/20 points: Platform support detection failed

Could not determine supported platforms as package resolution failed.

Run flutter pub get for more information.

failed
Pass static analysis
0 / 50trigger folding of the section

0/50 points: code has no errors, warnings, lints, or formatting issues

  • Running flutter pub outdated failed with the following output:
The lower bound of "sdk: '>=1.0.0 <=3.4.3'" must be 2.12.0'
or higher to enable null safety.
failed
Support up-to-date dependencies
0 / 40trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

  • Sdk constraint doesn't support current Dart version 3.4.3. Cannot run flutter pub outdated.

0/10 points: Package supports latest stable Dart and Flutter SDKs

Pubspec.yaml does not have an sdk version constraint.

Try adding an sdk constraint to your pubspec.yaml

* The current SDK constraint does not allow the Dart version used by the latest stable Flutter (3.4.3)

0/20 points: Compatible with dependency constraint lower bounds

flutter pub downgrade failed with:

OUT:
Resolving dependencies...
ERR:
The lower bound of "sdk: '>=1.0.0 <=3.4.3'" must be 2.12.0'
or higher to enable null safety.

The current Dart SDK (3.4.3) only supports null safety.

For details, see https://dart.dev/null-safety

Run flutter pub downgrade and then flutter analyze to reproduce the above problem.

You may run dart pub upgrade --tighten to update your dependency constraints, see dart.dev/go/downgrade-testing for details.

Analyzed with Pana 0.22.6, Flutter 3.22.2, Dart 3.4.3.

Check the analysis log for details.

4339
likes
15
pub points
100%
popularity

Publisher

verified publisherfluttercommunity.dev

The Font Awesome Icon pack available as Flutter Icons

Repository (GitHub)
View/report issues

License

unknown (LICENSE)

Dependencies

flutter

More

Packages that depend on font_awesome_flutter