flutterpackagepuredart 0.0.1

Flutter Android iOS

A new Flutter package pure dart.

0
likes
60 / 110
pub points
0 %
popularity

We analyzed this package on Sep 22, 2020, and awarded it 60 pub points (of a possible 110):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

10/10 points: 20% or more of the public API has dartdoc comments

  • 3 out of 7 API elements (42.9 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Consider supporting multiple platforms:

Package does not support Flutter platform Web

Because:

  • package:flutterpackagepuredart/flutterpackagepuredart.dart that imports:
  • package:url_launcher/url_launcher.dart that declares support for platforms: Android, iOS

Consider supporting these prerelease platforms:

Package does not support Flutter platform Windows

Because:

  • package:flutterpackagepuredart/flutterpackagepuredart.dart that imports:
  • package:url_launcher/url_launcher.dart that declares support for platforms: Android, iOS
Package does not support Flutter platform Linux

Because:

  • package:flutterpackagepuredart/flutterpackagepuredart.dart that imports:
  • package:url_launcher/url_launcher.dart that declares support for platforms: Android, iOS
Package does not support Flutter platform macOS

Because:

  • package:flutterpackagepuredart/flutterpackagepuredart.dart that imports:
  • package:url_launcher/url_launcher.dart that declares support for platforms: Android, iOS
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

INFO: Unused import: 'package:url_launcher/url_launcher.dart'.

lib/flutterpackagepuredart.dart:3:8

  ╷
3 │ import 'package:url_launcher/url_launcher.dart';
  │        ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/flutterpackagepuredart.dart

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
flutterflutter0.0.00.0.0
url_launcher^3.0.13.0.35.7.0
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.0.01.0.0
collection-1.14.131.14.13
meta-1.1.81.2.3
sky_engine-0.0.990.0.99
typed_data-1.2.01.2.0
vector_math-2.0.82.0.8

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^3.0.1` on url_launcher does not support the latest published version `5.7.0`

pubspec.yaml:13:17

   ╷
13 │   url_launcher: ^3.0.1
   │                 ^^^^^^
   ╵

10/10 points: Package supports latest stable Dart and Flutter SDKs

0
likes
60
pub points
0%
popularity

A new Flutter package pure dart.

Homepage

Documentation

API reference

Uploader

2502198967@qq.com

License

unknown (LICENSE)

Dependencies

flutter, url_launcher

More

Packages that depend on flutterpackagepuredart