flutterdoc 0.1.5

  • Readme
  • Changelog
  • Installing
  • 45

Flutterdoc #

pub

Installation #

pub global activate flutterdoc

Usage #

cd /path/to/your/widgets/lib
flutterdoc build

License #

MIT

0.1.5 #

  • Supports input and output folder config
  • Add init command

0.1.4 #

0.1.3 #

  • Handle deletion failure

0.1.2 #

  • Make it work after publishing

0.1.1 #

  • Google Analytics tracking ID config

0.1.0 #

  • First release

0.0.1 #

  • Initial version, created by Stagehand

Use this package as an executable

1. Install it

You can install the package from the command line:


$ pub global activate flutterdoc

2. Use it

The package has the following executables:


$ flutterdoc

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  flutterdoc: ^0.1.5

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter pub get

Alternatively, your editor might support pub get or flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:flutterdoc/flutterdoc.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
98
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
80
Overall:
Weighted score of the above. [more]
45
Learn more about scoring.

We analyzed this package on Oct 11, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.5.1
  • pana: 0.12.21

Platforms

Detected platforms: Flutter, other

Primary library: package:flutterdoc/flutterdoc.dart with components: io, isolate.

Health issues and suggestions

Document public APIs. (-1 points)

4 out of 4 API elements have no dartdoc comment.Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API.

Fix lib/flutterdoc.dart. (-1 points)

Analysis of lib/flutterdoc.dart reported 2 hints:

line 147 col 3: Future results in async function bodies must be awaited or marked unawaited using package:pedantic.

line 148 col 3: Future results in async function bodies must be awaited or marked unawaited using package:pedantic.

Maintenance issues and suggestions

Support latest dependencies. (-10 points)

The version constraint in pubspec.yaml does not support the latest published versions for 1 dependency (analyzer).

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and flutterdoc.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.4.0 <3.0.0
analyzer ^0.37.0 0.37.1+1 0.38.5
args ^1.5.2 1.5.2
dart_style ^1.2.10 1.2.10 1.3.1
dartdoc ^0.28.5 0.28.5 0.28.7
json_annotation ^3.0.0 3.0.0
path ^1.6.0 1.6.4
resource ^2.1.6 2.1.6
yaml ^2.2.0 2.2.0
Transitive dependencies
async 2.4.0
charcode 1.1.2
collection 1.14.12
convert 2.1.1
crypto 2.1.3
csslib 0.16.1
file 5.1.0
front_end 0.1.21+1 0.1.27
glob 1.1.7
html 0.14.0+3
http_parser 3.1.3
intl 0.16.0
kernel 0.3.21+1 0.3.27
logging 0.11.3+2
markdown 2.1.1
matcher 0.12.5
meta 1.1.7
mustache 1.1.1
package_config 1.1.0
platform 2.2.1
process 3.0.12
pub_semver 1.4.2
quiver 2.0.5
source_span 1.5.5
stack_trace 1.9.3
string_scanner 1.0.5
term_glyph 1.1.0
typed_data 1.1.6
watcher 0.9.7+12
Dev dependencies
build_runner ^1.7.0
json_serializable ^3.2.2
pedantic ^1.7.0 1.8.0+1
test ^1.5.0