fluttercontactpicker 4.7.0 copy "fluttercontactpicker: ^4.7.0" to clipboard
fluttercontactpicker: ^4.7.0 copied to clipboard

Use Androids' and iOS' native contact pickers to chose phone numbers and email addresses from contacts of the users address book

156
likes
130/ 140
pub points
97%
popularity

We analyzed this package 6 days ago, and awarded it 130 pub points (of a possible 140):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: BSD-3-Clause.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

66 out of 119 API elements (55.5 %) have documentation comments.

Some symbols that are missing documentation: fluttercontactpicker.Address.Address.fromMap, fluttercontactpicker.Contact, fluttercontactpicker.Contact.Contact, fluttercontactpicker.ContactPickerPlatform.available, fluttercontactpicker.ContactPickerPlatform.getAvailableProperties.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 3 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Web

These platforms are not supported:

Package does not support platform `Windows`.

Because:

  • package:fluttercontactpicker/fluttercontactpicker.dart that declares support for platforms: Android, iOS, Web.
Package does not support platform `Linux`.

Because:

  • package:fluttercontactpicker/fluttercontactpicker.dart that declares support for platforms: Android, iOS, Web.
Package does not support platform `macOS`.

Because:

  • package:fluttercontactpicker/fluttercontactpicker.dart that declares support for platforms: Android, iOS, Web.
partial
Pass static analysis
40 / 50trigger folding of the section

40/50 points: code has no errors, warnings, lints, or formatting issues

lib/src/interface.dart doesn't match the Dart formatter.

To format your files run: dart format .

OK
Support up-to-date dependencies
20 / 20trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
contact_picker_platform_interface ^4.7.0 4.7.0 4.7.0
contact_picker_web ^4.7.0 4.7.0 4.7.0
flutter flutter 0.0.0 0.0.0
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
collection - 1.18.0 1.18.0
flutter_web_plugins - 0.0.0 0.0.0
js - 0.6.7 0.7.1
material_color_utilities - 0.8.0 0.8.0
meta - 1.11.0 1.12.0
plugin_platform_interface - 2.1.8 2.1.8
sky_engine - 0.0.99 0.0.99
vector_math - 2.1.4 2.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.2, Flutter 3.19.1, Dart 3.3.0.

Check the analysis log for details.

156
likes
130
pub points
97%
popularity

Publisher

verified publisherrittmeister.in

Use Androids' and iOS' native contact pickers to chose phone numbers and email addresses from contacts of the users address book

Repository (GitHub)
View/report issues

Documentation

API reference

License

BSD-3-Clause (LICENSE)

Dependencies

contact_picker_platform_interface, contact_picker_web, flutter

More

Packages that depend on fluttercontactpicker