flutter_widget_collection 0.0.1
flutter_widget_collection: ^0.0.1 copied to clipboard

A Flutter package save everything widget favorite.

1
likes
80 / 110
pub points
28 %
popularity

We analyzed this package on Apr 13, 2021, and awarded it 80 pub points (of a possible 110):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

0/10 points: 20% or more of the public API has dartdoc comments

  • 23 out of 122 API elements (18.9 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
20 / 20

20/20 points: Supports 3 of 3 possible platforms (iOS, Android, Web)

Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 10 issues. Showing the first 2:

INFO: The value of the field '_festival' isn't used.

lib/src/utils/china_lunar_copy.dart:50:23

   ╷
50 │   Map<String, String> _festival = {
   │                       ^^^^^^^^^
   ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/src/utils/china_lunar_copy.dart

INFO: The value of the field '_lfestival' isn't used.

lib/src/utils/china_lunar_copy.dart:69:23

   ╷
69 │   Map<String, String> _lfestival = {
   │                       ^^^^^^^^^^
   ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/src/utils/china_lunar_copy.dart

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
flutterflutter0.0.00.0.0
providerany5.0.05.0.0
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.01.1.0
collection-1.15.01.15.0
meta-1.3.01.3.0
nested-1.0.01.0.0
sky_engine-0.0.990.0.99
typed_data-1.3.01.3.0
vector_math-2.1.02.1.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analysed with Pana 0.15.4, Flutter 2.0.4, Dart 2.12.2.

1
likes
80
pub points
28%
popularity

A Flutter package save everything widget favorite.

Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

minhminh9201@gmail.com

License

MIT (LICENSE)

Dependencies

flutter, provider

More

Packages that depend on flutter_widget_collection