flutter_vizzy_lib 1.0.6
flutter_vizzy_lib: ^1.0.6 copied to clipboard

Vizzy integration library for Flutter

0
likes
30 / 110
pub points
0 %
popularity

We analyzed this package on Apr 22, 2021, and awarded it 30 pub points (of a possible 110):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
0 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

0/10 points: 20% or more of the public API has dartdoc comments

  • 0 out of 64 API elements (0.0 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Consider supporting multiple platforms:

Package not compatible with runtime flutter-web on Web

Because:

  • package:flutter_vizzy_lib/Vizzy.dart that imports:
  • package:flutter_driver/flutter_driver.dart that imports:
  • package:flutter_driver/src/driver/timeline_summary.dart that imports:
  • package:flutter_driver/src/driver/common.dart that imports:
  • package:file/memory.dart that imports:
  • package:file/src/backends/memory.dart that imports:
  • package:file/src/backends/memory/style.dart that imports:
  • package:file/file.dart that imports:
  • package:file/src/interface.dart that imports:
  • package:file/src/io.dart that imports:
  • dart:io
Pass static analysis
0 / 30

0/30 points: code has no errors, warnings, lints, or formatting issues

Found 4 issues. Showing the first 2:

ERROR: Too many positional arguments: 0 expected, but 1 found.

lib/_VizzyApiClient.dart:18:49

   ╷
18 │   Future<UploadImageResponse> uploadImage(@Part('build_id') int buildId,
   │                                                 ^^^^^^^^^^
   ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/_VizzyApiClient.dart

ERROR: Too many positional arguments: 0 expected, but 1 found.

lib/_VizzyApiClient.dart:19:13

   ╷
19 │       @Part('image') File image, @Part('test_image_ancestry') String fileName);
   │             ^^^^^^^
   ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/_VizzyApiClient.dart

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
convert^2.1.12.1.13.0.0
crypto^2.1.32.1.53.0.1
dio^3.0.13.0.104.0.0
flutter_driverflutter0.0.00.0.0
json_annotation^3.0.03.1.14.0.1
json_serializable^3.0.03.5.14.1.1
meta^1.1.61.3.01.3.0
retrofit^1.2.01.3.4+11.3.4+1
Transitive dependencies
PackageConstraintCompatibleLatest
_fe_analyzer_shared-14.0.021.0.0
analyzer-0.41.21.5.0
archive-2.0.133.1.2
args-1.6.02.0.0
async-2.5.02.5.0
boolean_selector-2.1.02.1.0
build-1.6.22.0.1
build_config-0.4.71.0.0
characters-1.1.01.1.0
charcode-1.2.01.2.0
checked_yaml-1.0.42.0.1
cli_util-0.3.00.3.0
clock-1.1.01.1.0
collection-1.15.01.15.0
dart_style-1.3.122.0.0
fake_async-1.2.01.2.0
file-6.0.06.1.0
flutter-0.0.00.0.0
fuchsia_remote_debug_protocol-0.0.00.0.0
glob-2.0.12.0.1
http_parser-3.1.44.0.0
logging-1.0.11.0.1
matcher-0.12.100.12.10
package_config-1.9.32.0.0
path-1.8.01.8.0
pedantic-1.11.01.11.0
platform-3.0.03.0.0
process-4.0.04.2.1
pub_semver-2.0.02.0.0
pubspec_parse-0.1.81.0.0
sky_engine-0.0.990.0.99
source_gen-0.9.10+31.0.0
source_span-1.8.01.8.1
stack_trace-1.10.01.10.0
stream_channel-2.1.02.1.0
string_scanner-1.1.01.1.0
sync_http-0.2.00.3.0
term_glyph-1.2.01.2.0
test_api-0.2.190.4.0
typed_data-1.3.01.3.0
vector_math-2.1.02.1.0
vm_service-5.5.06.2.0
watcher-1.0.01.0.0
webdriver-2.1.23.0.0
yaml-3.1.03.1.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 5 issues. Showing the first 2:

The constraint `^2.1.1` on convert does not support the stable version `3.0.0`.

Try running dart pub upgrade --major-versions convert to update the constraint.

The constraint `^2.1.3` on crypto does not support the stable version `3.0.0`.

Try running dart pub upgrade --major-versions crypto to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analysed with Pana 0.15.4, Dart 2.12.2.