flutter_vehicle_keyboard 1.0.2 copy "flutter_vehicle_keyboard: ^1.0.2" to clipboard
flutter_vehicle_keyboard: ^1.0.2 copied to clipboard

Flutter Vehicle Keyboard 仿交管12123车牌键盘

1
likes
115/ 160
pub points
55%
popularity

We analyzed this package 3 days ago, and awarded it 115 pub points (of a possible 160):

failed
Follow Dart file conventions
5 / 30trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

The package description contains too many non-ASCII characters.

The site uses English as its primary language. The content of the description field in your package's pubspec.yaml should primarily contain characters used in English.

5/5 points: Provide a valid README.md

0/5 points: Provide a valid CHANGELOG.md

`CHANGELOG.md` contains too many non-ASCII characters.

The site uses English as its primary language. The content of CHANGELOG.md in your package should primarily contain characters used in English.

0/10 points: Use an OSI-approved license

No license was recognized.

Consider using an OSI-approved license in the LICENSE file to make it more accessible to the community.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

17 out of 37 API elements (45.9 %) have documentation comments.

Some symbols that are missing documentation: flutter_vehicle_keyboard, flutter_vehicle_keyboard.FlutterVehicleKeyboard, flutter_vehicle_keyboard.FlutterVehicleKeyboard.FlutterVehicleKeyboard, flutter_vehicle_keyboard.KeyDownEvent.KEYNAME_BACKSPACE, flutter_vehicle_keyboard.KeyDownEvent.KEYNAME_CLOSE.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 2 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS

These platforms are not supported:

Package does not support platform `Windows`.

Because:

  • package:flutter_vehicle_keyboard/flutter_vehicle_keyboard.dart that declares support for platforms: Android, iOS.
Package does not support platform `Linux`.

Because:

  • package:flutter_vehicle_keyboard/flutter_vehicle_keyboard.dart that declares support for platforms: Android, iOS.
Package does not support platform `macOS`.

Because:

  • package:flutter_vehicle_keyboard/flutter_vehicle_keyboard.dart that declares support for platforms: Android, iOS.
Package does not support platform `Web`.

Because:

  • package:flutter_vehicle_keyboard/flutter_vehicle_keyboard.dart that declares support for platforms: Android, iOS.
failed
Pass static analysis
30 / 50trigger folding of the section

30/50 points: code has no errors, warnings, lints, or formatting issues

Found 10 issues. Showing the first 2:

WARNING: This class (or a class that this class inherits from) is marked as '@immutable', but one or more of its instance fields aren't final: VehicleKeyboard.controller

lib/flutter_vehicle_keyboard.dart:8:7

  ╷
8 │ class VehicleKeyboard extends StatefulWidget {
  │       ^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/flutter_vehicle_keyboard.dart

WARNING: The left operand can't be null, so the right operand is never executed.

lib/flutter_vehicle_keyboard.dart:292:66

    ╷
292 │       int baseOffset = widget.controller.selection.baseOffset ?? 0;
    │                                                                  ^
    ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/flutter_vehicle_keyboard.dart

OK
Support up-to-date dependencies
40 / 40trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
flutter flutter 0.0.0 0.0.0
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
collection - 1.18.0 1.19.0
material_color_utilities - 0.8.0 0.12.0
meta - 1.12.0 1.15.0
sky_engine - 0.0.99 0.0.99
vector_math - 2.1.4 2.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

20/20 points: Compatible with dependency constraint lower bounds

pub downgrade does not expose any static analysis error.

Analyzed with Pana 0.22.9, Flutter 3.22.2, Dart 3.4.3.

Check the analysis log for details.

1
likes
115
pub points
55%
popularity

Publisher

unverified uploader

Flutter Vehicle Keyboard 仿交管12123车牌键盘

Repository (GitHub)
View/report issues

Documentation

API reference

License

unknown (license)

Dependencies

flutter

More

Packages that depend on flutter_vehicle_keyboard