flutter_utils_code 0.0.3

  • Readme
  • Changelog
  • Example
  • Installing
  • 55

flutter_utils_code #

pub

A Flutter utils package. pub.dev地址:flutter_utils_code-pub.dev

Getting Started #

APIs #

  • 正则相关 -> RegexUtils

isMobileExact:精确验证手机号
isMobileSimple:简单验证手机号
isEmail:验证邮箱
  • 正则相关 -> Toast

show: 显示
  • 栏相关 -> BarUtils

getStatusBarHeight: 获取状态栏高度
  • app相关 -> AppUtils

isAppDebug: 判断app是否为debug

0.0.1 #

  • initial release.
  • 添加正则类,包含手机号精准验证
  • 添加toast工具

0.0.2 #

  • 正则类:增加简单手机号验证 , 验证邮箱
  • 栏相关:增加获取状态栏高度

0.0.3 #

  • 新增示例代码
  • app相关:增加判断app是否为debug

example/README.md

example #

A new Flutter application.

Getting Started #

This project is a starting point for a Flutter application.

A few resources to get you started if this is your first Flutter project:

For help getting started with Flutter, view our online documentation, which offers tutorials, samples, guidance on mobile development, and a full API reference.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  flutter_utils_code: ^0.0.3

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:flutter_utils_code/flutter_utils_code.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
24
Health:
Code health derived from static analysis. [more]
96
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
70
Overall:
Weighted score of the above. [more]
55
Learn more about scoring.

We analyzed this package on Oct 21, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.5.1
  • pana: 0.12.21
  • Flutter: 1.9.1+hotfix.4

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Health suggestions

Fix lib/flutter_utils_code.dart. (-2.48 points)

Analysis of lib/flutter_utils_code.dart reported 5 hints:

line 37 col 20: Name non-constant identifiers using lowerCamelCase.

line 38 col 20: Name non-constant identifiers using lowerCamelCase.

line 39 col 20: Name non-constant identifiers using lowerCamelCase.

line 40 col 20: Name non-constant identifiers using lowerCamelCase.

line 41 col 20: Name non-constant identifiers using lowerCamelCase.

Fix lib/constant/constant.dart. (-1.49 points)

Analysis of lib/constant/constant.dart reported 3 hints:

line 5 col 23: Name non-constant identifiers using lowerCamelCase.

line 13 col 23: Name non-constant identifiers using lowerCamelCase.

line 16 col 23: Name non-constant identifiers using lowerCamelCase.

Format lib/view/toast.dart.

Run flutter format to format lib/view/toast.dart.

Maintenance suggestions

The package description is too short. (-20 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.11 1.14.12
meta 1.1.7
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
flutter_test