flutter_umeng_plugin: ^1.0.1 copied to clipboard
一个基于友盟IOS/Android 开发的一款分享 埋点插件
We analyzed this package on Jun 17, 2021, and awarded it 55 pub points (of a possible 130):
0/10 points: Provide a valid
The package description is too short.
Add more detail to the
description field of
pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.
The package description contains too many non-ASCII characters.
The site uses English as its primary language. The content of the
description field in your package's
pubspec.yaml should primarily contain characters used in English.
5/5 points: Provide a valid
0/5 points: Provide a valid
`CHANGELOG.md` contains too many non-ASCII characters.
The site uses English as its primary language. The content of
CHANGELOG.md in your package should primarily contain characters used in English.
10/10 points: Package has an example
- Found example at:
0/10 points: 20% or more of the public API has dartdoc comments
- 1 out of 26 API elements (3.8 %) have documentation comments.
Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.
10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)
Found 6 issues. Showing the first 2:
Consider supporting multiple platforms:
Package does not support Flutter platform Web
package:flutter_umeng_plugin/flutter_umeng_plugin.dartthat declares support for platforms: Android, iOS
20/30 points: code has no errors, warnings, lints, or formatting issues
lib/flutter_umeng_plugin.dart is not formatted according to dartfmt
To format your files run:
dartfmt -w .
0/10 points: All of the package dependencies are supported in the latest version
To reproduce run
dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.
The constraint `^2.0.0` on platform does not support the stable version `3.0.0`.
dart pub upgrade --major-versions platform to update the constraint.
10/10 points: Package supports latest stable Dart and Flutter SDKs