flutter_umeng_plugin 1.0.1
flutter_umeng_plugin: ^1.0.1 copied to clipboard

一个基于友盟IOS/Android 开发的一款分享 埋点插件

2
likes
55 / 130
pub points
0 %
popularity

We analyzed this package on Jun 17, 2021, and awarded it 55 pub points (of a possible 130):

Follow Dart file conventions
5 / 20

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

The package description contains too many non-ASCII characters.

The site uses English as its primary language. The content of the description field in your package's pubspec.yaml should primarily contain characters used in English.

5/5 points: Provide a valid README.md

0/5 points: Provide a valid CHANGELOG.md

`CHANGELOG.md` contains too many non-ASCII characters.

The site uses English as its primary language. The content of CHANGELOG.md in your package should primarily contain characters used in English.

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

0/10 points: 20% or more of the public API has dartdoc comments

  • 1 out of 26 API elements (3.8 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Found 6 issues. Showing the first 2:

Consider supporting multiple platforms:

Package does not support Flutter platform Web

Because:

  • package:flutter_umeng_plugin/flutter_umeng_plugin.dart that declares support for platforms: Android, iOS
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

lib/flutter_umeng_plugin.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
flutterflutter0.0.00.0.0
meta^1.0.41.3.01.4.0
platform^2.0.02.2.13.0.0
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.01.1.0
collection-1.15.01.15.0
sky_engine-0.0.990.0.99
typed_data-1.3.01.3.0
vector_math-2.1.02.1.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^2.0.0` on platform does not support the stable version `3.0.0`.

Try running dart pub upgrade --major-versions platform to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.1.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.17.1, Flutter 2.2.1, Dart 2.13.1.

2
likes
55
pub points
0%
popularity

Publisher

Unknown

一个基于友盟IOS/Android 开发的一款分享 埋点插件

Homepage

Documentation

API reference

License

LICENSE

Dependencies

flutter, meta, platform

More

Packages that depend on flutter_umeng_plugin