flutter_typeahead_web 1.0.0+1
flutter_typeahead_web: ^1.0.0+1 copied to clipboard

A highly customizable typeahead (autocomplete) text input field for Flutter with web support

19
likes
100 / 130
pub points
86 %
popularity

We analyzed this package on May 14, 2021, and awarded it 100 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 118 out of 164 API elements (72.0 %) have documentation comments.
Support multiple platforms
20 / 20

20/20 points: Supports 3 of 3 possible platforms (iOS, Android, Web)

Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 4 issues. Showing the first 2:

INFO: 'autovalidate' is deprecated and shouldn't be used. Use autovalidateMode parameter which provides more specific behavior related to auto validation. This feature was deprecated after v1.19.0..

lib/cupertino_flutter_typeahead.dart:102:13

    ╷
102 │             autovalidate: autovalidate,
    │             ^^^^^^^^^^^^
    ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/cupertino_flutter_typeahead.dart

INFO: 'maxLengthEnforced' is deprecated and shouldn't be used. Use maxLengthEnforcement parameter which provides more specific behavior related to the maxLength limit. This feature was deprecated after v1.25.0-5.0.pre..

lib/cupertino_flutter_typeahead.dart:731:9

    ╷
731 │         maxLengthEnforced: widget.textFieldConfiguration.maxLengthEnforced,
    │         ^^^^^^^^^^^^^^^^^
    ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/cupertino_flutter_typeahead.dart

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
flutterflutter0.0.00.0.0
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.01.1.0
collection-1.15.01.15.0
meta-1.3.01.3.0
sky_engine-0.0.990.0.99
typed_data-1.3.01.3.0
vector_math-2.1.02.1.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.5.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.16.0, Flutter 2.0.6, Dart 2.12.3.

19
likes
100
pub points
86%
popularity

A highly customizable typeahead (autocomplete) text input field for Flutter with web support

Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

sarbagyastha@gmail.com

License

BSD (LICENSE)

Dependencies

flutter

More

Packages that depend on flutter_typeahead_web