flutter_translation_sheet 1.0.6+14 icon indicating copy to clipboard operation
flutter_translation_sheet: ^1.0.6+14 copied to clipboard

Flutter Translation Sheet Generator is a super simple tool to help you deal with localization (l10n), using automatic GoogleSheet translations (via Google Translate) and the generation of json and dart files.

29
likes
80/ 130
pub points
56%
popularity

We analyzed this package 16 days ago, and awarded it 80 pub points (of a possible 130):

icon indicating section status
Follow Dart file conventions
10 / 20icon to trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

The package description is too long.

Search engines display only the first part of the description. Try to keep the value of the description field in your package's pubspec.yaml file between 60 and 180 characters.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

icon indicating section status
Provide documentation
0 / 20icon to trigger folding of the section

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

0/10 points: 20% or more of the public API has dartdoc comments

  • 20 out of 139 API elements (14.4 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

icon indicating section status
Platform support
20 / 20icon to trigger folding of the section

20/20 points: Supports 3 of 6 possible platforms (iOS, Android, Web, Windows, MacOS, Linux)

  • ✓ Windows
  • ✓ Linux
  • ✓ MacOS

These platforms are not supported:

Package does not support platform `Android`.

Because:

  • package:flutter_translation_sheet/flutter_translation_sheet.dart that imports:
  • package:flutter_translation_sheet/src/samples/generator.dart that imports:
  • package:flutter_translation_sheet/src/utils/utils.dart that imports:
  • package:flutter_translation_sheet/src/utils/logger.dart that imports:
  • package:dcli/dcli.dart that declares support for platforms: Windows, Linux, macOS.
Package does not support platform `iOS`.

Because:

  • package:flutter_translation_sheet/flutter_translation_sheet.dart that imports:
  • package:flutter_translation_sheet/src/samples/generator.dart that imports:
  • package:flutter_translation_sheet/src/utils/utils.dart that imports:
  • package:flutter_translation_sheet/src/utils/logger.dart that imports:
  • package:dcli/dcli.dart that declares support for platforms: Windows, Linux, macOS.
Package does not support platform `Web`.

Because:

  • package:flutter_translation_sheet/flutter_translation_sheet.dart that imports:
  • package:flutter_translation_sheet/src/samples/generator.dart that imports:
  • package:flutter_translation_sheet/src/utils/utils.dart that imports:
  • package:flutter_translation_sheet/src/utils/logger.dart that imports:
  • package:dcli/dcli.dart that declares support for platforms: Windows, Linux, macOS.

These issues are present but do not affect the score, because they may not originate in your package:

Package not compatible with platform Windows

Because:

  • package:flutter_translation_sheet/flutter_translation_sheet.dart that imports:
  • package:flutter_translation_sheet/src/samples/generator.dart that imports:
  • package:flutter_translation_sheet/src/utils/utils.dart that imports:
  • package:flutter_translation_sheet/src/utils/logger.dart that imports:
  • package:dcli/dcli.dart that imports:
  • package:dcli/src/util/wait_for_ex.dart that imports:
  • dart:cli
Package does not support platform `Linux`.

Because:

  • package:flutter_translation_sheet/flutter_translation_sheet.dart that imports:
  • package:flutter_translation_sheet/src/samples/generator.dart that imports:
  • package:flutter_translation_sheet/src/utils/utils.dart that imports:
  • package:flutter_translation_sheet/src/utils/logger.dart that imports:
  • package:dcli/dcli.dart that imports:
  • package:dcli/src/util/terminal.dart that imports:
  • package:dart_console/dart_console.dart that imports:
  • package:dart_console/src/console.dart that imports:
  • package:dart_console/src/ffi/win/termlib-win.dart that imports:
  • package:win32/win32.dart that declares support for platforms: Windows.
Package does not support platform `macOS`.

Because:

  • package:flutter_translation_sheet/flutter_translation_sheet.dart that imports:
  • package:flutter_translation_sheet/src/samples/generator.dart that imports:
  • package:flutter_translation_sheet/src/utils/utils.dart that imports:
  • package:flutter_translation_sheet/src/utils/logger.dart that imports:
  • package:dcli/dcli.dart that imports:
  • package:dcli/src/util/terminal.dart that imports:
  • package:dart_console/dart_console.dart that imports:
  • package:dart_console/src/console.dart that imports:
  • package:dart_console/src/ffi/win/termlib-win.dart that imports:
  • package:win32/win32.dart that declares support for platforms: Windows.
icon indicating section status
Pass static analysis
20 / 30icon to trigger folding of the section

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 23 issues. Showing the first 2:

INFO: The value of the local variable 'res' isn't used.

bin/main.dart:14:9

   ╷
14 │     var res = await runner.run(args).onError((err, stackTrace) {
   │         ^^^
   ╵

To reproduce make sure you are using the lints_core and run dart analyze bin/main.dart

INFO: The import of 'package:googleapis_auth/googleapis_auth.dart' is unnecessary because all of the used elements are also provided by the import of 'package:googleapis_auth/auth_io.dart'.

lib/src/gsheets/gsheets.dart:14:8

   ╷
14 │ import 'package:googleapis_auth/googleapis_auth.dart';
   │        ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/src/gsheets/gsheets.dart

icon indicating section status
Support up-to-date dependencies
10 / 20icon to trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
args^2.2.02.3.12.3.1
collection^1.15.01.16.01.16.0
dcli^1.7.11.31.21.31.2
googleapis^4.0.04.0.09.1.0
googleapis_auth^1.1.01.3.11.3.1
http^0.13.30.13.40.13.4
path^1.8.01.8.21.8.2
recase^4.0.04.0.04.0.0
yaml^3.1.03.1.13.1.1
Transitive dependencies
PackageConstraintCompatibleLatest
_discoveryapis_commons-1.0.31.0.3
archive-3.3.03.3.0
async-2.9.02.9.0
basic_utils-3.9.44.2.2
chunked_stream-1.4.11.4.1
circular_buffer-0.10.00.11.0
convert-3.0.23.0.2
crypto-3.0.23.0.2
csv-5.0.15.0.1
dart_console-1.0.01.0.0
dcli_core-1.31.21.31.2
equatable-2.0.32.0.3
ffi-1.2.12.0.0
file-6.1.26.1.2
file_utils-1.0.11.0.1
glob-2.0.22.0.2
globbing-1.0.01.0.0
http_parser-4.0.14.0.1
ini-2.1.02.1.0
js-0.6.40.6.4
json_annotation-4.5.04.5.0
logging-1.0.21.0.2
matcher-0.12.110.12.11
meta-1.8.01.8.0
mime-1.0.21.0.2
pointycastle-3.6.03.6.0
posix-3.1.03.1.0
pub_semver-2.1.12.1.1
pubspec-2.2.02.2.0
quiver-3.1.03.1.0
random_string-2.3.12.3.1
scope-2.2.12.2.1
settings_yaml-3.4.13.4.1
source_span-1.9.01.9.0
stack_trace-1.10.01.10.0
stacktrace_impl-2.3.02.3.0
string_scanner-1.1.11.1.1
system_info2-2.0.42.0.4
term_glyph-1.2.01.2.0
typed_data-1.3.11.3.1
uri-1.0.01.0.0
uuid-3.0.63.0.6
validators2-3.0.03.0.0
vin_decoder-0.2.1-nullsafety0.2.1-nullsafety
win32-2.6.12.7.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^4.0.0` on googleapis does not support the stable version `5.0.0`.

Try running dart pub upgrade --major-versions googleapis to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

icon indicating section status
Support sound null safety
20 / 20icon to trigger folding of the section

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.21.12, Dart 2.17.1.

29
likes
80
pub points
56%
popularity

Publisher

unverified uploader

Flutter Translation Sheet Generator is a super simple tool to help you deal with localization (l10n), using automatic GoogleSheet translations (via Google Translate) and the generation of json and dart files.

Repository (GitHub)
View/report issues

Documentation

API reference

License

Icon for licenses.MIT (LICENSE)

Dependencies

args, collection, dcli, googleapis, googleapis_auth, http, path, recase, yaml

More

Packages that depend on flutter_translation_sheet