flutter_translate 1.2.1

  • Readme
  • Changelog
  • Example
  • Installing
  • new59

flutter_translate #

Build Status pub package GitHub issues License: MIT Flutter.io


The internationalization (i18n) library for Flutter.

It lets you define translations for your content in different languages and switch between them easily.

[1.0.0]

  • Initial release.

[1.0.1]

  • Removed the flutter_localizations dependency.

[1.0.2]

  • Simplified the localization initialization.

[1.1.0]

  • Implemented a global translate method.
  • Removed the static Translate class.
  • Localization is now a singleton.

[1.2.0]

  • Implemented pluralization
  • Fixed multiple issues
  • translate, translatePlural and changeLanguage methods are now global

example/README.md

example #

Example project for the flutter_translate library

Getting Started #

This project is a starting point for a Flutter application.

A few resources to get you started if this is your first Flutter project:

For help getting started with Flutter, view our online documentation, which offers tutorials, samples, guidance on mobile development, and a full API reference.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  flutter_translate: ^1.2.1

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:flutter_translate/flutter_translate.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
17
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
100
Overall:
Weighted score of the above. [more]
59
Learn more about scoring.

We analyzed this package on Oct 13, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.5.1
  • pana: 0.12.21
  • Flutter: 1.9.1+hotfix.4

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Health suggestions

Format lib/constants.dart.

Run flutter format to format lib/constants.dart.

Format lib/global.dart.

Run flutter format to format lib/global.dart.

Format lib/localization.dart.

Run flutter format to format lib/localization.dart.

Fix additional 6 files with analysis or formatting issues.

Additional issues in the following files:

  • lib/localization_configuration.dart (Run flutter format to format lib/localization_configuration.dart.)
  • lib/localization_delegate.dart (Run flutter format to format lib/localization_delegate.dart.)
  • lib/localization_file_service.dart (Run flutter format to format lib/localization_file_service.dart.)
  • lib/localization_provider.dart (Run flutter format to format lib/localization_provider.dart.)
  • lib/localized_app.dart (Run flutter format to format lib/localized_app.dart.)
  • lib/localized_app_state.dart (Run flutter format to format lib/localized_app_state.dart.)

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.11 1.14.12
meta 1.1.7
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8