flutter_tide 0.7.3
flutter_tide: ^0.7.3 copied to clipboard

A very thin layer on top of state_notifier and provider to give guidelines when architecturing an application.

0
likes
90 / 110
pub points
0 %
popularity

We analyzed this package on Apr 13, 2021, and awarded it 90 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 6 out of 21 API elements (28.6 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Consider supporting multiple platforms:

Package not compatible with runtime flutter-web on Web

Because:

  • package:flutter_tide/flutter_tide.dart that imports:
  • package:flutter_tide/src/persisted_provider.dart that imports:
  • package:tide/tide.dart that imports:
  • package:tide/src/persistence/json_file.dart that imports:
  • dart:io
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
flutterflutter0.0.00.0.0
flutter_state_notifier^0.6.10.6.10.7.0
provider^4.3.2+24.3.35.0.0
state_notifier^0.6.00.6.00.7.0
tide^0.6.40.6.50.6.5
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.01.1.0
collection-1.15.01.15.0
meta-1.3.01.3.0
nested-1.0.01.0.0
sky_engine-0.0.990.0.99
typed_data-1.3.01.3.0
vector_math-2.1.02.1.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 3 issues. Showing the first 2:

The constraint `^0.6.1` on flutter_state_notifier does not support the stable version `0.7.0`.

Try running dart pub upgrade --major-versions flutter_state_notifier to update the constraint.

The constraint `^4.3.2+2` on provider does not support the stable version `5.0.0`.

Try running dart pub upgrade --major-versions provider to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analysed with Pana 0.15.4, Flutter 2.0.4, Dart 2.12.2.

0
likes
90
pub points
0%
popularity

A very thin layer on top of state_notifier and provider to give guidelines when architecturing an application.

Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

alois.deniel@gmail.com

License

MIT (LICENSE)

Dependencies

flutter, flutter_state_notifier, provider, state_notifier, tide

More

Packages that depend on flutter_tide