flutter_themez 2.0.9 copy "flutter_themez: ^2.0.9" to clipboard
flutter_themez: ^2.0.9 copied to clipboard

A simple wrapper for Flutter's ThemeData. Including "light" and "dark".

1
likes
150/ 160
pub points
51%
popularity

We analyzed this package 39 hours ago, and awarded it 150 pub points (of a possible 160):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: BSD-3-Clause.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

21 out of 22 API elements (95.5 %) have documentation comments.

Some symbols that are missing documentation: flutter_themez.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS
  • ✓ Web
partial
Pass static analysis
40 / 50trigger folding of the section

40/50 points: code has no errors, warnings, lints, or formatting issues

Found 17 issues. Showing the first 2:

INFO: The part-of directive uses a library name.

lib/src/extensions.dart:1:1

  ╷
1 │ part of flutter_themez;
  │ ^^^^^^^^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/extensions.dart

INFO: The part-of directive uses a library name.

lib/src/flutter_themez.dart:1:1

  ╷
1 │ part of flutter_themez;
  │ ^^^^^^^^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/flutter_themez.dart

OK
Support up-to-date dependencies
40 / 40trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
flutter flutter 0.0.0 0.0.0
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
collection - 1.18.0 1.19.0
material_color_utilities - 0.8.0 0.12.0
meta - 1.12.0 1.15.0
sky_engine - 0.0.99 0.0.99
vector_math - 2.1.4 2.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

20/20 points: Compatible with dependency constraint lower bounds

pub downgrade does not expose any static analysis error.

Analyzed with Pana 0.22.7, Flutter 3.22.2, Dart 3.4.3.

Check the analysis log for details.

1
likes
150
pub points
51%
popularity

Publisher

verified publishermj12358.dev

A simple wrapper for Flutter's ThemeData. Including "light" and "dark".

Repository (GitHub)
View/report issues

Topics

#flutter #theme

Documentation

API reference

Funding

Consider supporting this project:

www.buymeacoffee.com

License

BSD-3-Clause (LICENSE)

Dependencies

flutter

More

Packages that depend on flutter_themez