flutter_tc_player 0.0.5
flutter_tc_player: ^0.0.5

A new Flutter plugin.

0
likes
40 / 110
pub points
0 %
popularity

We analyzed this package on Nov 22, 2020, and awarded it 40 pub points (of a possible 110):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

Homepage URL doesn't exist.

At the time of the analysis https://www.pub.org was unreachable.

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

0/10 points: 20% or more of the public API has dartdoc comments

  • 13 out of 78 API elements (16.7 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Found 6 issues. Showing the first 2:

Consider supporting multiple platforms:

Package does not support Flutter platform Web

Because:

  • package:flutter_tc_player/flutter_tc_player.dart that declares support for platforms: Android, iOS
Pass static analysis
0 / 30

0/30 points: code has no errors, warnings, lints, or formatting issues

ERROR: The named parameter 'isInitialRoute' isn't defined.

lib/view/tencent_player.dart:48:31

   ╷
48 │       settings: RouteSettings(isInitialRoute: false),
   │                               ^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/view/tencent_player.dart

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
wakelock^0.1.3+40.1.4+20.2.1+1
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.0-nullsafety.51.1.0-nullsafety.5
collection-1.15.0-nullsafety.51.15.0-nullsafety.5
meta-1.3.0-nullsafety.61.3.0-nullsafety.6
typed_data-1.3.0-nullsafety.51.3.0-nullsafety.5
vector_math-2.1.0-nullsafety.52.1.0-nullsafety.5

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.1.3+4` on wakelock does not support the latest published version `0.2.1+1`

pubspec.yaml:13:13

   ╷
13 │   wakelock: ^0.1.3+4
   │             ^^^^^^^^
   ╵

10/10 points: Package supports latest stable Dart and Flutter SDKs

0
likes
40
pub points
0%
popularity

A new Flutter plugin.

Homepage

Documentation

API reference

Uploader

mrblack8922@outlook.com

License

unknown (LICENSE)

Dependencies

flutter, wakelock

More

Packages that depend on flutter_tc_player