flutter_tabler 0.3.1 copy "flutter_tabler: ^0.3.1" to clipboard
flutter_tabler: ^0.3.1 copied to clipboard

Just the Tabler.

2
likes
80/ 140
pub points
43%
popularity

We analyzed this package 35 hours ago, and awarded it 80 pub points (of a possible 140):

failed
Follow Dart file conventions
20 / 30trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

13 out of 53 API elements (24.5 %) have documentation comments.

Some symbols that are missing documentation: flutter_tabler, flutter_tabler.Tabler, flutter_tabler.Tabler.Tabler, flutter_tabler.Tabler.columns, flutter_tabler.Tabler.controller.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS
  • ✓ Web
failed
Pass static analysis
0 / 50trigger folding of the section

0/50 points: code has no errors, warnings, lints, or formatting issues

ERROR: The getter 'headline4' isn't defined for the type 'TextTheme'.

lib/flutter_tabler.dart:51:64

   ╷
51 │                             style: Theme.of(context).textTheme.headline4,
   │                                                                ^^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/flutter_tabler.dart

OK
Support up-to-date dependencies
20 / 20trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
bloc ^8.0.3 8.1.4 8.1.4
flutter flutter 0.0.0 0.0.0
flutter_bloc ^8.0.1 8.1.5 8.1.5
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
collection - 1.18.0 1.18.0
material_color_utilities - 0.8.0 0.11.1
meta - 1.12.0 1.15.0
nested - 1.0.0 1.0.0
provider - 6.1.2 6.1.2
sky_engine - 0.0.99 0.0.99
vector_math - 2.1.4 2.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.3, Flutter 3.22.0, Dart 3.4.0.

Check the analysis log for details.