flutter_svg 0.19.2+1
flutter_svg: ^0.19.2+1
flutter_svg: ^0.20.0-nullsafety.0

Flutter Android iOS

An SVG rendering and widget library for Flutter, which allows painting and displaying Scalable Vector Graphics 1.1 files.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

dependencies:
  flutter_svg: ^0.19.2+1

2. Install it

You can install packages from the command line:

with Flutter:

$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:flutter_svg/flutter_svg.dart';
781
likes
100
pub points
99%
popularity

Publisher

dnfield.dev

An SVG rendering and widget library for Flutter, which allows painting and displaying Scalable Vector Graphics 1.1 files.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

flutter, meta, path_drawing, vector_math, xml

More

Packages that depend on flutter_svg