flutter_slack_oauth_firebase 0.4.2
flutter_slack_oauth_firebase: ^0.4.2 copied to clipboard

Flutter Android iOS

Extension on the flutter_slack_oauth library that handles login via Firebase Auth and FireStore.

0
likes
80 / 110
pub points
0 %
popularity

We analyzed this package on Jan 26, 2021, and awarded it 80 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

0/10 points: 20% or more of the public API has dartdoc comments

  • 2 out of 20 API elements (10.0 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Found 9 issues. Showing the first 2:

Consider supporting multiple platforms:

Package does not support Flutter platform Web

Because:

  • package:flutter_slack_oauth_firebase/flutter_slack_oauth_firebase.dart that imports:
  • package:flutter_webview_plugin/flutter_webview_plugin.dart that declares support for platforms: Android, iOS
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
firebase_auth^0.14.0+20.14.0+90.20.0+1
flutter_slack_oauth^0.4.0+10.4.0+10.4.0+1
flutter_webview_plugin^0.3.30.3.110.3.11
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.0-nullsafety.51.1.0-nullsafety.5
charcode-1.1.31.1.3
collection-1.15.0-nullsafety.51.15.0-nullsafety.5
ffi-0.1.30.1.3
file-5.2.15.2.1
firebase-7.3.38.0.0
firebase_core-0.4.50.7.0
firebase_core_platform_interface-1.0.43.0.1
firebase_core_web-0.1.1+20.2.1+3
http-0.12.20.12.2
http_parser-3.1.43.1.4
intl-0.16.10.16.1
js-0.6.3-nullsafety.30.6.3-nullsafety.3
matcher-0.12.90.12.9
meta-1.3.0-nullsafety.61.3.0-nullsafety.6
path-1.7.01.7.0
path_provider_linux-0.0.1+20.0.1+2
path_provider_platform_interface-1.0.41.0.4
path_provider_windows-0.0.4+30.0.4+3
pedantic-1.9.21.9.2
platform-2.2.12.2.1
plugin_platform_interface-1.0.31.0.3
process-3.0.133.0.13
quiver-2.1.52.1.5
shared_preferences-0.5.12+40.5.12+4
shared_preferences_linux-0.0.2+40.0.2+4
shared_preferences_macos-0.0.1+110.0.1+11
shared_preferences_platform_interface-1.0.41.0.4
shared_preferences_web-0.1.2+70.1.2+7
shared_preferences_windows-0.0.2+20.0.2+2
source_span-1.7.01.7.0
stack_trace-1.9.61.9.6
string_scanner-1.0.51.0.5
term_glyph-1.1.01.1.0
typed_data-1.3.0-nullsafety.51.3.0-nullsafety.5
vector_math-2.1.0-nullsafety.52.1.0-nullsafety.5
win32-1.7.41.7.4
xdg_directories-0.1.20.1.2

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.14.0+2` on firebase_auth does not support the latest published version `0.20.0+1`

pubspec.yaml:12:18

   ╷
12 │   firebase_auth: ^0.14.0+2
   │                  ^^^^^^^^^
   ╵

10/10 points: Package supports latest stable Dart and Flutter SDKs

0
likes
80
pub points
0%
popularity

Extension on the flutter_slack_oauth library that handles login via Firebase Auth and FireStore.

Repository (GitHub)
View/report issues

Documentation

API reference

Uploaders

thomas.stockx@kunstmaan.be
kris.pypen@kunstmaan.be

License

MIT (LICENSE)

Dependencies

firebase_auth, flutter, flutter_slack_oauth, flutter_webview_plugin

More

Packages that depend on flutter_slack_oauth_firebase