flutter_simple_video_player 0.0.9

flutter simple video player

2
likes
40 / 110
pub points
74 %
popularity

We analyzed this package on Oct 30, 2020, and awarded it 40 pub points (of a possible 110):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

0/10 points: 20% or more of the public API has dartdoc comments

  • 2 out of 14 API elements (14.3 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Consider supporting multiple platforms:

Package does not support Flutter platform Web

Because:

  • package:flutter_simple_video_player/flutter_simple_video_player.dart that imports:
  • package:screen/screen.dart that declares support for platforms: Android, iOS

Consider supporting these prerelease platforms:

Package does not support Flutter platform Windows

Because:

  • package:flutter_simple_video_player/flutter_simple_video_player.dart that imports:
  • package:screen/screen.dart that declares support for platforms: Android, iOS
Package does not support Flutter platform Linux

Because:

  • package:flutter_simple_video_player/flutter_simple_video_player.dart that imports:
  • package:screen/screen.dart that declares support for platforms: Android, iOS
Package does not support Flutter platform macOS

Because:

  • package:flutter_simple_video_player/flutter_simple_video_player.dart that imports:
  • package:screen/screen.dart that declares support for platforms: Android, iOS
Pass static analysis
0 / 30

0/30 points: code has no errors, warnings, lints, or formatting issues

Found 4 issues. Showing the first 2:

ERROR: The named parameter 'isInitialRoute' isn't defined.

lib/flutter_simple_video_player.dart:124:33

    ╷
124 │         settings: RouteSettings(isInitialRoute: false),
    │                                 ^^^^^^^^^^^^^^
    ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/flutter_simple_video_player.dart

INFO: This class (or a class that this class inherits from) is marked as '@immutable', but one or more of its instance fields aren't final: SimpleViewPlayer.isFullScreen

lib/flutter_simple_video_player.dart:7:7

  ╷
7 │ class SimpleViewPlayer extends StatefulWidget {
  │       ^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/flutter_simple_video_player.dart

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
flutterflutter0.0.00.0.0
screen^0.0.40.0.50.0.5
video_player^0.10.0+20.10.12+50.11.1+2
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.0-nullsafety.31.1.0-nullsafety.4
collection-1.15.0-nullsafety.31.15.0-nullsafety.4
flutter_web_plugins-0.0.00.0.0
meta-1.3.0-nullsafety.31.3.0-nullsafety.5
sky_engine-0.0.990.0.99
typed_data-1.3.0-nullsafety.31.3.0-nullsafety.4
vector_math-2.1.0-nullsafety.32.1.0-nullsafety.4
video_player_platform_interface-2.2.02.2.0
video_player_web-0.1.40.1.4

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.10.0+2` on video_player does not support the latest published version `0.11.1+2`

pubspec.yaml:11:17

   ╷
11 │   video_player: ^0.10.0+2
   │                 ^^^^^^^^^
   ╵

10/10 points: Package supports latest stable Dart and Flutter SDKs