flutter_shimmer_widget 1.0.0
flutter_shimmer_widget: ^1.0.0 copied to clipboard

A package provides an easy way to add shimmer effect in Flutter project

6
likes
100 / 130
pub points
76 %
popularity

We analyzed this package on May 14, 2021, and awarded it 100 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 19 out of 40 API elements (47.5 %) have documentation comments.
Support multiple platforms
20 / 20

20/20 points: Supports 3 of 3 possible platforms (iOS, Android, Web)

Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 3 issues. Showing the first 2:

INFO: 'List' is deprecated and shouldn't be used. Use a list literal, [], or the List.filled constructor instead.

lib/flutter_shimmer_loading_widget.dart:103:32

    ╷
103 │     final List<int> listTemp = List(widget.count);
    │                                ^^^^
    ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/flutter_shimmer_loading_widget.dart

INFO: 'overflow' is deprecated and shouldn't be used. Use clipBehavior instead. See the migration guide in flutter.dev/go/clip-behavior. This feature was deprecated after v1.22.0-12.0.pre..

lib/flutter_shimmer_loading_widget.dart:208:25

    ╷
208 │                         overflow: Overflow.clip,
    │                         ^^^^^^^^
    ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/flutter_shimmer_loading_widget.dart

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
flutterflutter0.0.00.0.0
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.01.1.0
collection-1.15.01.15.0
meta-1.3.01.3.0
sky_engine-0.0.990.0.99
typed_data-1.3.01.3.0
vector_math-2.1.02.1.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.7.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.16.0, Flutter 2.0.6, Dart 2.12.3.

6
likes
100
pub points
76%
popularity

A package provides an easy way to add shimmer effect in Flutter project

Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

tuanla1@ssi.com.vn

License

MIT (LICENSE)

Dependencies

flutter

More

Packages that depend on flutter_shimmer_widget