flutter_sharing_intent 1.1.1 copy "flutter_sharing_intent: ^1.1.1" to clipboard
flutter_sharing_intent: ^1.1.1 copied to clipboard

A flutter plugin that allow flutter apps to receive photos, videos, text, urls or any other file types from another app.

62
likes
140/ 140
pub points
94%
popularity

We analyzed this package 2 days ago, and awarded it 140 pub points (of a possible 140):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: Apache-2.0.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

12 out of 32 API elements (37.5 %) have documentation comments.

Some symbols that are missing documentation: flutter_sharing_intent, flutter_sharing_intent.FlutterSharingIntent, flutter_sharing_intent.FlutterSharingIntent.FlutterSharingIntent, flutter_sharing_intent.FlutterSharingIntent.getPlatformVersion, flutter_sharing_intent.FlutterSharingIntent.instance.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 2 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS

These platforms are not supported:

Package does not support platform `Windows`.

Because:

  • package:flutter_sharing_intent/flutter_sharing_intent.dart that declares support for platforms: Android, iOS.
Package does not support platform `Linux`.

Because:

  • package:flutter_sharing_intent/flutter_sharing_intent.dart that declares support for platforms: Android, iOS.
Package does not support platform `macOS`.

Because:

  • package:flutter_sharing_intent/flutter_sharing_intent.dart that declares support for platforms: Android, iOS.
Package does not support platform `Web`.

Because:

  • package:flutter_sharing_intent/flutter_sharing_intent.dart that declares support for platforms: Android, iOS.
OK
Pass static analysis
50 / 50trigger folding of the section

50/50 points: code has no errors, warnings, lints, or formatting issues

OK
Support up-to-date dependencies
20 / 20trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
flutter flutter 0.0.0 0.0.0
plugin_platform_interface ^2.1.8 2.1.8 2.1.8
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
collection - 1.18.0 1.18.0
material_color_utilities - 0.8.0 0.8.0
meta - 1.11.0 1.12.0
sky_engine - 0.0.99 0.0.99
vector_math - 2.1.4 2.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.0, Flutter 3.19.0, Dart 3.3.0.

Check the analysis log for details.

62
likes
140
pub points
94%
popularity

Publisher

verified publishertechind.co

A flutter plugin that allow flutter apps to receive photos, videos, text, urls or any other file types from another app.

Repository (GitHub)
View/report issues

Documentation

API reference

License

Apache-2.0 (LICENSE)

Dependencies

flutter, plugin_platform_interface

More

Packages that depend on flutter_sharing_intent