flutter_session 0.1.1 icon indicating copy to clipboard operation
flutter_session: ^0.1.1 copied to clipboard

Adds session support to Flutter. Works with mobile, web and (hopefully) desktop builds.

209
likes
110/ 140
pub points
92%
popularity

We analyzed this package 3 days ago, and awarded it 110 pub points (of a possible 140):

icon indicating section status
Follow Dart file conventions
30 / 30icon to trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

icon indicating section status
Provide documentation
20 / 20icon to trigger folding of the section

10/10 points: Package has an example

10/10 points: 20% or more of the public API has dartdoc comments

  • 4 out of 7 API elements (57.1 %) have documentation comments.
icon indicating section status
Platform support
20 / 20icon to trigger folding of the section

20/20 points: Supports 5 of 6 possible platforms (iOS, Android, Web, Windows, MacOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Linux
  • ✓ MacOS
  • ✓ Web

These platforms are not supported:

Package does not support platform `Windows`.

Because:

  • package:flutter_session/flutter_session.dart that imports:
  • package:shared_preferences/shared_preferences.dart that declares support for platforms: Android, iOS, Linux, macOS, Web.

These issues are present but do not affect the score, because they may not originate in your package:

Package does not support platform `Android`.

Because:

  • package:flutter_session/flutter_session.dart that imports:
  • package:shared_preferences/shared_preferences.dart that imports:
  • package:shared_preferences_windows/shared_preferences_windows.dart that declares support for platforms: Windows.
Package does not support platform `iOS`.

Because:

  • package:flutter_session/flutter_session.dart that imports:
  • package:shared_preferences/shared_preferences.dart that imports:
  • package:shared_preferences_windows/shared_preferences_windows.dart that declares support for platforms: Windows.
Package does not support platform `Linux`.

Because:

  • package:flutter_session/flutter_session.dart that imports:
  • package:shared_preferences/shared_preferences.dart that imports:
  • package:shared_preferences_windows/shared_preferences_windows.dart that declares support for platforms: Windows.
Package does not support platform `macOS`.

Because:

  • package:flutter_session/flutter_session.dart that imports:
  • package:shared_preferences/shared_preferences.dart that imports:
  • package:shared_preferences_windows/shared_preferences_windows.dart that declares support for platforms: Windows.
Package does not support platform `Web`.

Because:

  • package:flutter_session/flutter_session.dart that imports:
  • package:shared_preferences/shared_preferences.dart that imports:
  • package:shared_preferences_windows/shared_preferences_windows.dart that declares support for platforms: Windows.
icon indicating section status
Pass static analysis
30 / 30icon to trigger folding of the section

30/30 points: code has no errors, warnings, lints, or formatting issues

icon indicating section status
Support up-to-date dependencies
10 / 20icon to trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
flutterflutter0.0.00.0.0
shared_preferences^0.5.80.5.12+42.0.17
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.2.11.2.1
collection-1.17.01.17.1
ffi-1.2.12.0.1
file-6.1.46.1.4
flutter_web_plugins-0.0.00.0.0
js-0.6.50.6.7
material_color_utilities-0.2.00.2.0
meta-1.8.01.9.0
path-1.8.31.8.3
path_provider_linux-0.0.1+22.1.7
path_provider_platform_interface-1.0.42.0.5
path_provider_windows-0.0.52.1.3
platform-3.1.03.1.0
plugin_platform_interface-1.0.32.1.3
process-4.2.44.2.4
shared_preferences_linux-0.0.2+42.1.3
shared_preferences_macos-0.0.1+112.0.5
shared_preferences_platform_interface-1.0.42.1.0
shared_preferences_web-0.1.2+72.0.4
shared_preferences_windows-0.0.2+32.1.3
sky_engine-0.0.990.0.99
vector_math-2.1.42.1.4
win32-2.6.14.1.1
xdg_directories-0.1.20.2.0+3

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.5.8` on shared_preferences does not support the stable version `2.0.0`.

Try running dart pub upgrade --major-versions shared_preferences to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

icon indicating section status
Support sound null safety
0 / 20icon to trigger folding of the section

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.7.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.21.25, Flutter 3.7.0, Dart 2.19.0.

209
likes
110
pub points
92%
popularity

Publisher

unverified uploader

Adds session support to Flutter. Works with mobile, web and (hopefully) desktop builds.

Repository (GitHub)

Documentation

API reference

License

Icon for licenses.MIT (LICENSE)

Dependencies

flutter, shared_preferences

More

Packages that depend on flutter_session